A quick fix on "not getting ads" issue

for those who still are not getting any ads for awhile now…

go to brave://flags/
search for: enable system notifications. choose "enable from the dropdown
search for: Enable Brave Rewards verbose logging. “enable” as well
click on “relaunch”

goto brave://rewards-internals
click on logs

wallah! problem solved!

tested it on a windows pc. * i haven’t tested it on other devices

have a great day ahead of you people!


Thanks. Done.

Not sure I’ll get much use as this is like my 5th device and Uphold limits an account to 4 devices. Hope they’ll change that.

doesn’t work on Mac!

I cant see Enalbe brave rewards verbose logging.

It does on my mac. Macbook Pro 2019, Catalina v 10.15.7 (I haven’t gotten around to installing Big Sur yet.) and most current version of Brave, which is v 1.31.87.
Actually, I just found this thread and I was able to do as suggested for the fix, but since it’s only been a few minutes I can’t tell if I’ll start receiving ads. I’ll try to remember to come back here and tell you if I do. My Brave Rewards ads suddenly stopped after July this year and I’ve been trying to find out why ever since. Hope this fix works.
Update: About a half hour has passed and I’m not receiving any ads, so there’s something else going on. I looked in the logs and keep seeing this: “[Oct 23, 2021, 8:35:48.0 PM:INFO:ad_notification_serving.cc(101)] Ad notification not served: Not allowed due to permission rules.” I looked in Brave Settings and don’t know where to go in there to see Permissions specific to Brave Rewards. I can see Permissions specific to many websites, but I don’t see anything at all for Brave. Can anyone advise?

check if notifications are turned on for the app, choose Apple menu > System Preferences, click Notifications, select the app on the left, then click Allow Notifications on the right (blue indicates notifications are turned on).

I’m on a Macbook Pro (details listed above), and I don’t think there’s such a thing as “apps” on laptops or desktops, so when you said to select the app, I selected “Brave Browser.” And I already had it set to allow Notifications.
Here is what I see in the log: “VERBOSE2:permission_rule_util.cc(25)] You do not have enough unblinded tokens”
and this one too: "Ad notification not served: Not allowed due to permission rules.” Need help. I’ve done everything I can think of regarding Permissions. I also don’t understand the meaning of “unblinded tokens.” Thanks for being there to help.

well, I et ads, but that isn’t the issue - the ads are not counted and my BAT has been on 0 since maybe… April? Or earlier. I cannot remember, have tried to fix it many times but to no avail and I am still waiting on answers from the dev team.

sorry to hear that. so i guess its not working on macs. i only tried it on 4 windows desktop and it works fine ever since. anyways goodluck on your trouble i hope it would be fixed the soonest though support team are overwhelmed at the moment.

Thanks monyak, this fixed my “not getting ads” issue on windows 8.1 like a charm! I had not seen an ad for several days (and the rewards-internals logs were showing pairs of “Notifications not allowed” “Ad notification not served: Not allowed due to permission rules” errors) but this fixed it back to the expected ad behavior and frequency.

Hey @bdram did you find a solution to this problem ?
i am facing a similar problem on windows

No! And I’m rather peeved about it. In my log files I keep seeing the line about “you don’t have enough unblinded tokens” as well as “permissions” aren’t correct to allow payments. I can’t find any info on the unblinded token thing ANYWHERE and that’s what I’m most angry about. As for the permissions, I’ve scoured my laptop’s settings as thoroughly as possible and nothing works. Please let me know if you figure anything out. And thanks for asking. If you know any other place besides this stinking forum to get legit help with Brave Rewards, please tell me where.

1 Like

yeah i have the exact same error, its very irritating

this is a post that i made.

there is a possibility that our wallets might have been flagged by brave for suspicious activity or something
i am also not able to find info about it anywhere either and the support team is not replying.

other than this forum i tried finding it on reddit but was very unsuccessful

I haven’t gotten any ads since June! This really sucks.

it’s been 3 days i don’t receive the ad, for some reason? who can help me

Same here, no ads for months. Need help from support on this.

I haven’t gotten one ad since activating a month ago.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.