Zotero Connecter broken

Description of the issue:

I installed the Zotero Connector plugin from the web store and it has been working with Zotero to collect papers for a while. Today, it stopped working. I followed the steps on Zotero troubleshooting to no avail.. Other people have had this problem as well.

The one thing I did which may have contributed to the problem was that I installed Zotero Connector to a second profile in Brave. It only stopped working after that.

I deleted the browsing and extension data in More Tool → Clear Browsing Data → Advanced → All checkboxes selected over past 24 hours for both Profiles, but this didn’t help.

I’m using Windows 10.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Install Zotero by clicking “Download” here: https://www.zotero.org/
  2. Install the “Zotero Connector” plugin from the Chrome store
  3. Open the Zotero program
  4. Try to capture a reference using Zotero Connector (any webpage will do, or try a random paper from PubMed)
  5. The connector should import the paper as expected.
  6. Now, in a second profile in Brave, install the plugin, too.
  7. Try to get another reference with the Zotero program still open in either profile
  8. Will get an “Is Zotero running?” error that cannot be fixed by any troubleshooting step on the Zotero troubleshooting site linked above.

Actual Result (gifs and screenshots are welcome!):
Get an "Is Zotero Running? error

The error message (the Zotero program was running when this occured:

The Zotero Connector Plugin interface doesn’t see Zotero anymore. Here’s the plugin’s settings page:

Expected result:
Zotero captures the reference in the main program

Reproduces how often:
Always.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Pro 2004 with Brave 1.21.73.

Additional Information:
Others are having a similar problem. See the Zotero forum here for more info: https://forums.zotero.org/discussion/87066/brave-browser-zotero-connector-cannot-contact-zotero-desktop-app#latest

Just chiming in, have the same problem…

I am able to load the URL to port 23119 (as suggested on the Troubleshooting page) but wasn’t able to actually connect to Zotero…

Zotero suggests whitelisting 127.0.0.1 port 23119 but unsure how to do this in Brave.

I am on macOS Sierra 10.12.6 with Brave 1.21.73

Just installed Brave today, any help would be much appreciated!

Over at the Zotero forums, they say that Brave is not supported so we should stick with a supported browser: Chrome, Firefox, or Safari.

So I guess this is primarily a Brave issue. It’d be great if Brave could work well with Zotero Connector in the future.

I am a bit confused about why Brave was working, but then stopped. It’s either me installing it on two profiles, or a Brave update that nerfed it.

1 Like

Hi,
I use zotero plugin w brave w/o any problem.
Try to use an earlier version of brave.
I am on linux using Version 1.17.73 Chromium: 87.0.4280.67 (Official Build) (64-bit)

1 Like

It’s Brave, I was using the connector as I usually do and last night it stopped working. I love Brave, but it seems that now things have gone wrong or maybe they are starting to censor extensions in favor of others or important developments in their browser are starting to slip out of their hands.

Anyway, it seems that now we will have to switch to Chrome again, something I never thought I would do.

Thanks biohegedus. I’d like to try that but am unsure how to install an earlier version for windows. I know I can find it earlier versions on Github, but the .exe just installs the latest one. I’m unsure how to run an installer to get the earlier version.

Hi. go to settings and set ‘Trackers & ads blocking’ to ‘Disabled’
Problem solved.

2 Likes

Ok, it seems like the best solution is to either:

(i) Revert to an earlier version of Brave
(ii) Set ‘Trackers & ads blocking’ to ‘Disabled’ whenever you want to use Zotero.

I’ll try (i) first… As a sidenote it’s amazing how frequent Brave releases are! I wonder how recent of a “break” this is.

It would be helpful in the future if we could whitelist Zotero or something like that, I don’t see why Zotero shouldn’t work with Brave.

Thanks all!

Initially reverted to 1.21.70 and still didn’t work…

Finally reverted to 1.17.73 as suggested by @biohegedus and it works! Thanks!!

1 Like

Yep, turning off trackers and ad blocking works for me, too. Kinda defeats the purpose of using Brave, though.

Something must have broken Zotero Connector between 1.17.73 and 1.21.73, since it worked for me previously.

Hopefully Brave whitelists Zotero Connector in a future update.

2 Likes

I wonder if Brave blocking non-secure http localhosts has something to do with it. My understanding is that’s the connection needed for the Zotero plugin to work, and other people have complained aout this on Brave’s forums.

1 Like

I found a solution! Go to brave://adblock and enter @@127.0.0.1:23119 into custom filters. This whitelists localhost port 23119, which is the one Zotero uses.

I adapted this solution from here, another extension had the same problem.

Huzzah! That worked for me. Thanks for the solution, rhezab!

For others, you can also access the menu where you add the custom filter by clicking the right hamburger menu, and selecting “Brave Ad Block”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.