Zip File Download from FAILS

Description of the issue:
Given a link to ZIP file on, clicking that link using Firefox OR Safari works, BUT Brave throws an error and does not even get started with download.

Exact URL of the website in question: (204.7 MB) =>

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Does the site work as expected when using Chrome?

Brave version (check About Brave):
Version 1.17.75 Chromium: 87.0.4280.88 (Official Build) (x86_64)

Try to download it by pasting the direct link in your browser, you can also choose to open an anonymous Brave Browser window and check if it works for you, check the download folder in the settings and that everything is correct.

I try to access the website with two types of browsers and it appears completely collapsed, my impression is that the problem comes from the website.


Thanks for making contact so quickly.

I have tried direct paste into URL, but get same results.

Would you mind trying this from your end? (204.7 MB) =>

Let me know if you can download the Zip


Try firefox. It seems to work.

Try to access the URL and it Crashes almost Instantly, try with two browsers and the same thing happens, until the moment I try to hit the button, I can’t get the direct URL it keeps happening, the problem is on the web page, I recommend you that you upload it to

Hi Victor:

Which browsers did you try?

I discussed this problem with GoDaddy’s SecureServer team, and they said it is a browser problem.

To me, it doesn’t matter where the problem is, as long as I can get it fixed.

Let me know if you discover something.


Do you want me to upload the download to another server?

Hi Victor:

The URL works with TOR browser as well.

Chrome and Brave (based upon Chrome) are still not working with this URL.


The same happens with my servers hosted in the United States, friend the problem is the website I have no doubt.


Did you put the ZIP file on a different server, and can you test if that worked?


I put it in 2 different countries and the web page still does not work, you can look for an alternative since Downloading .ZIP files in Brave I have never had problems, the last one I downloaded was Zip from the United States server and without problem, I download more than 200gb daily from different servers and I have never had the problem I have with this one using Chrome and Brave Browser

Download Firefox and it worked perfectly, I downloaded the file and I have uploaded it to in case it helps you, but the website has its SSL certificate problems that is why it does not access the Google or Brave servers, here you go The download link will be easier for you to download from

Removed as the user obtained the link and downloaded.

Edit: Clean file of viruses and checked only deals with photos of a large volume of weight.


Thanks for isolating the problem to SSL certificates with GoDaddy when using Brave or Google.

I have forwarded your comments to GoDaddy to assist their troubleshooting.

I gather that you trust as a good file transfer site, so I will have a look at that if I cannot get the GoDaddy site working. The strange thing is that GoDaddy file download has been working for many years, except within the last month or two, something changed there.

Thanks for your help.
Garry. I use it for all my projects they have kept my files for years and I have never had any problems with them either when downloading or uploading files.

I am glad to have helped you, select my username as “Solved” and close the topic to proceed to delete the download link of this article, I will have the file for a period of 1 week or 1 month without any problem, so you can download it as many times as you want.


Lilian at GoDaddy was unable to observe the problem. Her download link worked, for both Win and Mac machines. So, GoDaddy is at a loss as to how to resove this for me.

I have used GoDaddy for many years for hosting web site and email services, as will as file transfer, so I will try kicking the cat for a few more days before I totally give up.

I will mark Solved and close the topic later tonight (6 pm here now).

Thanks again for your excellent and fast responses.


The same for you, always fight for what you want and do not give up, if you keep in touch notify them of the error and they have to solve it for the named browsers, they should not lose users if the platform belongs to them.

Good day.

Hi Victor & Lilian:

I tried the URL to download on my MacBook Pro (2012) running OS Mojave, and it works,

But, the same URL on my iMac (2009) running OS High Sierra does not work.

It looks like the problem is something in either hardware or OS

Thanks everybody for your assistance.

Case closed.

1 Like

Mark solved and close the topic in case other users have the same problem which they can easily find.

It is a pleasure to help you, have a good day.

I can’t figure out how to close the case. I have marked Solved. Can you close for me?

1 Like