Z fold 4, graphical issues

Description of the issue:
Graphical tearing and pixelation, delayed display of the tabs at the top of the browser.

How can this issue be reproduced?

  1. Newest brave release for android on fully updated z fold 4 (us att 500gb)
  2. Close all tabs so none are open and only the “+” is displayed
  3. Click the “+”

Expected result:
Tabs show normal no graphical errors.
Brave Version( check About Brave):

Mobile Device details
Zfold 4, 500gb, android 12, one ui version 4.1.1
Additional Information:
I have uninstalled and reinstalled as well rebooted device. No issues on chrome.

1 Like

This also appears on tabs when you scroll and the tabs/address bar fold up. When you scroll up and they re reveal they show as the screen shot attached then auto correct several seconds after.

1 Like

I’m experiencing the same issue on my Galaxy Tab S8+ which just got updated to Android 12L (OneUI 4.1.1)

1 Like

I’m also getting this issue on my S22+

Same issue on the Zfold 4
OneUI 4.1.1 Android 12

Issue happens on both Screens (Running higher dp 410/823 but makes no difference)



Try enabling vulkan in brave://flags

So the issue that most of you are experiencing is because Vulkan has been disabled. We have an issue created for this via https://github.com/brave/brave-browser/issues/25124.

We had a lot of issues with older devices not rendering the screen correctly when Vulkan was originally enabled. Users would see either black or white screens. So we disabled it via Griffin as per https://github.com/brave/brave-variations/pull/73.

However, with Chromium 105 being released, it looks like some of the newer devices require Vulkan to be enabled to work correctly. So we’re starting to gradually enable Vulkan as per https://github.com/brave/brave-variations/pull/359. We’ve enabled it starting at 10%.

You should be able to resolve these issue by enabling brave://flags#enable-vulkan.

Can confirm enabling vulkan fixed the issue.