YouTube TV isn't working - "This video format isn't supported"

Description of the issue:
How can this issue be reproduced?

  1. Try to watch any video on Youtube TV on MacOS 10.14.6
  2. You get the error message “This video format isn’t supported”

Expected result:

Video plays

Brave Version( check About Brave):
1.0.0

Additional Information:
I did enable the Widevine extension when it came up but that didn’t work.

@melvinram,
Can you tell me what your Shields settings are set to for Youtube TV?

It doesn’t work even if the Shield is set to Down

Previously, this was my settings:

Also, I did restart the browser just as a sanity check.

@melvinram,
Seems to be working fine on my end. Can you show me a screen shot of both the error screen as its displayed on your end and a screenshot of the dev tools console window? To find this, while on the page, press option + cmd + i to bring up the dev tools window, then select the Console tab.

Here you go:

Here’s the debug info:

{
  "ns": "yt",
  "el": "detailpage",
  "cpn": "PjWJf_bnC2eWwWPz",
  "docid": "OszwJ1oNEdM",
  "ver": 2,
  "referrer": "https://tv.youtube.com/watch/OszwJ1oNEdM?vp=0gEEEgIwAQ%3D%3D",
  "cmt": "0",
  "ei": "sJfMXdK4LJbZhgbk742oCQ",
  "fs": "0",
  "rt": "212.323",
  "of": "Z5KURErj55Xx5pCpjEOU2A",
  "euri": "",
  "lact": 8,
  "live": "dvr",
  "cl": "279737747",
  "mos": 0,
  "osid": "AAAAAKkud6s:AOeUNAbuUurHmbd3tYXkfBKXq45IPQVXeA",
  "state": "80",
  "vm": "CAEQABgEKiB1bnk3SDdPbWtzNWpFSEMtMV9wQmc5eEFBUGRRWTlQMkAB",
  "volume": 100,
  "c": "WEB_UNPLUGGED",
  "cver": "0.1",
  "cplayer": "UNIPLAYER",
  "ctheme": "UNPLUGGED",
  "cplatform": "DESKTOP",
  "delay": 5,
  "hl": "en_US",
  "cr": "US",
  "fexp": "21561001,23709574,23723208,23744176,23768780,23804281,23806743,23832924,23835668,23837040,23837772,23837993,23838769,23839190,23839361,23839597,23842630,23842881,23842986,23845648,23846545,23846757,23848795,23856652,23857013,23857013,23857365,23857493,23858305,23858320,23858831,23858831,9449243,9458116,9474357",
  "lio": "1573686844.876",
  "uoo": "1_2",
  "upt": "CgM4MDcSBTk0MTAzGgJVUw",
  "vct": "0.000",
  "vd": "NaN",
  "vpl": "",
  "vbu": "",
  "vpa": "1",
  "vsk": "0",
  "ven": "0",
  "vpr": "1",
  "vrs": "0",
  "vns": "0",
  "vec": "null",
  "vvol": "1",
  "debug_error": {
    "errorCode": "fmt.noneavailable",
    "errorMessage": "This video format is not supported.",
    "No": "HTML5_NO_AVAILABLE_FORMATS_FALLBACK",
    "Fg": "",
    "Py": "buildRej.1;a.0;d.1;f18.0;c18.1;f43.0;c43.1;f133.0;f140.0;c140.1;f242.0;c242.1"
  },
  "prerolls": "heartbeat",
  "ismb": 19910000,
  "latency_class": "NORMAL",
  "segduration": 5,
  "lat": 0,
  "relative_loudness": "NaN",
  "user_qual": "auto",
  "debug_videoId": "OszwJ1oNEdM",
  "0sz": false,
  "op": "",
  "yof": true,
  "dis": "",
  "gpu": "AMD_Radeon_Pro_555X_OpenGL_Engine",
  "cgr": true,
  "debug_playbackQuality": "unknown",
  "debug_date": "Wed Nov 13 2019 15:57:56 GMT-0800 (Pacific Standard Time)"
}

@melvinram,
Thank you for that. I’m going to dig into this a bit further – in the meantime, can you try disabling Hardware Acceleration and see if that makes a difference?

Settings --> Additional Settings --> System --> Hardware Acceleration

I tried that as well. Didn’t work.