Youtube playback tearing up when dGPU outputs over iGPU

When my Nvdia RTX 2070 Super outputs its image over the Intel 13900K iGPU then Youtube videos show tearing most of the time.

How can this issue be reproduced?

  1. Switch display to iGPU input.
  2. Start Youtube video playback, sometimes multiple videos are needed.
  3. When videos show tearing, switch Display input put dGPU (Nvidia) to see the same video without tearing (alternatively switch to Chrome or Firefox).

Expected result:
No tearing in Youtube videos.

Brave Version( check About Brave):
Version 1.48.171 Chromium: 110.0.5481.177 (Offizieller Build) (64-Bit)

Hello @Timur, thank you for reaching us out. Can you please try disabling the following settings to see if they resolve the issue:

Settings > System > Use hardware acceleration when available

Also going to: brave://flags > Search "Vulkan" > Disable Vulkan > Retest

Hope this can help you. Regards.

Thanks. I will test the Vulkan option, but disabling Hardware Acceleration is not an option anyone should be asked to do other than for troubleshooting analysis.

For the time being it seems that disabling Vulkan fixed the tearing, but curiously re-enabling Vulkan did not bring it back?! I will watch this for a while.

Hello @Timur, let us know what is the final outcome of this. Regards.

1 Like

Ahoi. Screen tearing starting happening again today. This time I did not disable + re-enable Vulkan, but switched the Vulkan option straight from “Default” to “Enabled”. Same result, the tearing stopped.

I will keep this enabled now to see if tearing happens again later on.

And I had to set Vulkan to “Disabled” instead. Turns out that Youtube “Shorts” are incompatible with (Brave’s) Vulkan implementation. It turns both videos and the Brave UI to flickering and some UI elements even jump around several pixels. I tried both the Intel iGPU and Nvidia dGPU (via both outputs), same result.

Nope, the screen tearing returns quite immediately. Sometimes it may not seem like it, because it moves vertically and video content doesn’t always reveal it.

But every time Brave uses the NVidia GPU over the Intel iGPU output it happens. The workaround is to either make Brave use the Intel iGPU itself or switch to the dGPU output without going through the iGPU.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.