Youtube blocking brave again

Same issue here, also doing it when some embedded Youtube videos come up in other pages.

All the people I saw mentioning this (crashing when loading Youtube) earlier were using really far outdated versions of Brave on Android 7, Windows 7, Windows 8, etc. Are you also on an outdated and unsupported version of Brave or what OS and version of Brave are you using?

Can you test in a clean Brave profile, try opening Youtube in Brave Beta.

Just a heads up for other users, uBO authors updated the YT filters, a few hours ago. It should fix the ads issue we saw:

confirmed… working again for me.

i guess the uBO guys don’t do weekends?

1 Like

Its all volunteer, As much as we want a fix got youtube asap, its takes time to debug changes, then work out the best way to fix and counter.

1 Like

@fanboynz good to know. Btw, any ideas if older versions might be kind of negatively impacted on some of the newer filters? Kind of referencing where people say it stops crashing if they turn off Shields. But otherwise visiting YouTube (and possibly other Google content) was crashing their browser.

Trick is they seemed to be on Windows 8.1, Windows 7, Android 6, etc.

Guess more specifically confirming if anyone experiencing issues like that on unsupported versions are basically SOL and on their own?

Win 7/8 hasn’t got many filters, if they have to stick with win7/8. Installing uBO and disabling shields globally (ads & trackers) might be the only solution in these cases.

If you’re on win10, 11, Mac or Linux. Using the latest version of Brave is best. No additional extensions needed.

1 Like

How do you turn it off globally?

I am using version 1.57.62 of the Brave App on Android 13 and since yesterday when opening the youtube site it crashes unless I allow all trackers and ads. I never had this issue before. Using Kiwi Browser I have no problemes, but unlike Brave Kiwi supports extensions, funnily enough in the same way as the desktop version of Brave, a.k.a using Chrome extensions and what not. Kiwi though has the same problemes as the current version of Brave for me as in the “tab has been closed” message, when closing a tab which was part of a tab group, taking a whole minute to disappear. Version 1.57.62 of Brave Mobile is as far as I know the ONLY version of the app which has the tab group feature, but doesn’t display the “tab has been closed” message at all, but seeing as only a handful of people have this problem for whatever reason, it’ll never be “fixed”.

If you’re on win7/8, just brave://settings/shields change there

Thanks! It’s over now. Man, this drove me up the wall but at least an uninstall cleaned some stuff out so that’s nice.

Why are you on windows 7/8 still?

The PC is not powerful enough to run W10 and it surely won’t do it without an SSD. I have a Dell Optiplex 380 and it has a busted spring in the power button that now won’t shut off or on without some jiggling. It remains on 24/7 now as I should’ve done all along as it doesn’t consume much power.

Sounds good. Not sure how long the Chrome store will offer up MV2 extensions (like uBO MV2). Maybe sideloading the extension an option when its no longer updated.

Because windows 10 is kinda trash, many of us are POOR and we’re highly proficient at using software that we have zero need to update because it basically does everything we need. Such is life.

I really don’t know. I should back up mine somehow before this happens but I have no clue about where they are or how to go about it.

Don’t worry about it, just install uBO on win7. Disable shields ads&trackers. At least for the time being that’s working.

That only worked for my brother’s account. It’s doing this on mine now lol! Now I somehow need to fix this. EDIT: Nuking my old profile and starting over fixed it!

Youtube and discord no abren, se cierra el navegaor automaticamente.

It’s definitely win 7/8 related. Though it crashed once on a Win 10 machine but after it restored the window I could never recreate it. Same exact behavior that one single instance.

Got it crashing on one win 7 machine and not another, actual matching model machines. Going in and dropping the shields, going into YouTube, then disabling Shields with the icon for only YouTube, going back in and turning on global shields seems to be running relatively stable at this point. I also had some crashing on google search/services, which I couldn’t reliably reproduce but have dropped the shields and now relatively stable.

Rolling along with tampermonkey script to ditch YT ads until I fully migrate to Win 10.

1 Like