Your website... was not verified because we were redirected too many times to verify your domain -- No redirects!

Briefly describe your issue: I am unable to verify our site to receive Brave rewards/tips from viewers.

What Operating System and Brave version are you using (Menu --> About Brave)? Windows 10 build 19042.985
Brave version 1.24.85 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no) Yes

What date did you verify your wallet? March 2021

Have you been able to successfully receive payments in the past? Yes

Are you using a VPN? (yes/no) Yes

Are you in a supported region (see here for list of supported regions)? Yes

Does your device pass the SafteyNet check (Android only)? Not using Android

Have you manually turned off Auto-contribute on all of your devices linked to Uphold?? No


I’m unable to verify our website regardless of the method used. Whether I’m using the WordPress app or the trusted file, any attempt at verification fails, and I get the error “Your website was not verified because we were redirected too many times to verify your domain. Please reduce the number of redirects.” I have determined through ping, nslookup, the online Redirect Checker ( https://smallseotools.com/redirect-checker/ ) and simple browser usage that there are no redirects. I’d like to know what’s wrong and what I can do to remedy this. I have tried disconnecting from our VPN and repeating the process; this didn’t work.

I know there is a similar topic here: Can't verify domain cause ...were redirected too many times , however, the topic was closed without an answer and I cannot comment that I am experiencing the same issue. As such, while I apologize for the duplicate topic, I feel this is a serious issue that needs to be addressed.

@Sutorippu,
Thank you reporting and the detailed writeup.
Can you try disabling HTTPSE in the Shields panel and attempt verification again?

Mattches please reply to me I really need your help my account was debited with 5000 dollars and they disabled me to purchase crypto or send

@Mattches Thank you for the reply and the suggestion. Unfortunately, this didn’t work. I still receive the same error.

1 Like

@Sutorippu,
Happy to help, sad it didn’t solve the issue. Do you have any extensions installed at this time?

I have Adblock Plus, Lustre, Crypto Wallets, and Wombat. On a whim, I’m going to disable ABP and see if that works…

aaand it didn’t. It was worth a try.

1 Like

@Sutorippu,
It definitely was worth a try thank you for taking action yourself and testing it out. I would actually go a step further and try the process in a private browsing window and see if you get the same behavior.

@Mattches I gave that a try, but unfortunately the error persists. I made doubly sure by disabling the VPN and trying again from the private window, but it still didn’t work.

1 Like

@Sutorippu,
Thank you for checking – will return as soon as I have more information.

1 Like

@Mattches Any luck? Do you need more info out of me?

Very sorry for the lack of response. I’m just getting back from the long weekend here let me see what I can find out about your situation.

1 Like

@Sutorippu,
Can you tell me the URL of the website you’re trying to verify?

1 Like

@Mattches Messaged you the URL.

Your website is redirecting.

Try going to your website /.well-known/brave-rewards-verification.txt

You don’t get the file, you get redirected to the WWW version of your website, and the request path is not kept – you’re redirected to the WWW root. Ideally for this to work, don’t redirect us to WWW, and keep the PATH and return the upload file.

1 Like

It looks like WordPress does this by default. I will post again when I have found a solution that doesn’t involve years-old versions of it.

Edit: Just for documentation purposes, the .well-known directory was in fact in the www_root directory. I moved it to the root directory for testing purposes and am giving it some time in case DNS has to update, but if this isn’t part of the problem then I’ll be looking at other options.

Edit 2: Moving it to the root didn’t help the way I wanted. It did however result in a 404, meaning that the location of the folder has to be in the www_root directory to be “found”. (This is how our webhost is configured; it includes a cgi-bin folder as well, which we don’t use.) Does that present a problem?

As long as the file is accessible at either the root or the www subdomain, it should work. Right now it is at neither.

Just to completely rule out that possibility I’ve created the directory in both uh, directories. The file within them is identical.

Edit: The file just isn’t being found. But I can guarantee you that it is there.
brave-ver1
brave-ver2

So, obviously I have traced the redirecting problem to the file just not being recognized as present. But as you can see by the above screenshots, it is there. What am I doing wrong?

Edit: I tried setting the file permissions on both to 0777, but that didn’t work, so I reset them for security purposes.

Edit edit: The problem seems to stem from .well-known being a hidden directory and therefore being blocked from public access by default, not with the file itself. I tried whitelisting .well-known in my .htaccess file, but that just broke the site, so I undid my changes.

The problem has been solved.

I got in contact with our provider and they were able to apply the proper access to the folder for verification.

Thank you for all of your help and patience. This thread can now be closed.

1 Like