Where are my passwords!

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

brave losing all or some of its passwords


I am running 1.18.75 on duvean ( debian ).

It appears if the pc goes to sleep, after waking, brave loses some - and occasionally all - of its passwords?
Same if I suspend the system.
A reboot or shutdown, seems to recover them.
Sometimes reboot doesn’t recover them
A shutdown and restart works every time.

Anyone experiencing this?

Many Thanks


Brave Version( check About Brave):

Additional Information:

When you launched the browser, were you prompted to grant Brave access?

Thanks for the reply.

Sorry - don’t quite know what you mean?

The only thing I occasionally get asked for is keyring authorisation - is that what you mean?

Otherwise, i do not get any other requests for access


So is this solved or not? I wonder whats happen after this, honestly. I am used to this kind of ‘who cares’ dealing problems. Waiting for them to solve my problem for so long now that my nerves start to boil. :roll_eyes: I am loosing points on a daily basis, email with instructions never came, and how can I verify account? This looks like complicated way to set up things.

Yes, I suspect that might be the request I’m referring to. Were you prompted to grant Brave access when you launched 1.18.75? If so, did you deny access? See Brave Browser wants to use your confidential information stored in "Brave Safe Storage" in your keychain? for more context. I hope this helps!

Hello, @EneaMay. Are you referring to an issue unrelated to this thread? If so, please create a new thread (or find an existing one) for the issue(s) you’re facing. Happy to assist!

I have never ‘denied’ access to these services - although I have not been asked for them everytime I use the browser- usually only after a reboot or shutdown.

I still dont understand why this may cause the loss of 'some ’ of my passwords?

I am currently in my brave settings looking at my passwords - instead of the usual 28 saved passwords, the list has now gone to only 4 saved passwords?

I will need to reboot to regain them all again.
It will be interesting to check if I am ALWAYS asked for keyring authorisation, after a reboot or shutdown - unfortunately, I cannot remember off hand whether it does.

I will run a few tests.


When Brave (as is the case with all Chromium browsers) is installed, it creates a 128-bit random password and stores it in a secure location (e.g. Keychain on macOS, Keyring or LibSecret on Linux). Brave uses this password to encrypt browser files on the system (this way, an attacker with access to the files would need to know the random 128-bit password to decrypt them). Version 1.18.75 of Brave was built differently (e.g. different cert or provisioning profile), and therefore lost access to it’s password for macOS users (quite possibly Linux too). In these cases, the user must grant v1.18.75 access for Brave to continue reading/writing it’s own files. I hope this helps!

Hi Sampson,

thanks for the reply.

Still not sure what is going on.
I have spent the last few days suspending, restarting, suhtting down my pc to try to recreate the problem.
it didn’t seem to have any effect?
Yet , I can be browsing for a while, and then suddenly, I cannot auto fill credentials on a site , and I go look in settings, and I am down to four ( instead of 28) saved passwords!
This has happened twice, without any apparent connection to any activity?
A restart always solves the issue - but I don’t need to give Brave permissions when this happens?

I wondered about looking at extensions? - I only have three , but two appear to have permissions to alter files.
I will start with Ublock, and see what happens for a day?
Worth trying?



Hello, @pootler. If you’re experiencing odd occurrences while using Brave, you are absolutely correct that the best approach is to reduce the number of variables as much as possible. Please note that if you’re on 1.18.75 or later, are using macOS, and have not yet granted Brave access to its Brave Safe Storage, that too could cause access-issues for passwords and more.

Our team also recently authored a guide on how to create a new profile for more successful troubleshooting, you can read it here: Create a new profile to help Troubleshoot. If there is anything I can do to assist you during this process, please do not hesitate to reach out.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.