Website issue since update and reinstall not working

  1. Mailonline (, one of the most popular news sites out there, causes Brave to crash as soon as you complete URL. I have tried clearing all website data, and a full reinstall twice. When I reinstall and open Brave the first time , it freezes on the ‘open page’ which asks if you want to make Brave default Browser. I have to close the app and reopen at which time it the message states ‘Brave closed unexpectedly , do you want to restore tabs’ . When the app is brand new install, from IOS App Store, why would it do that??

  2. Another issue is that my cache clearing choices(Clear Private Data)do not keep. I have always chosen to not delete saved logins/ cookies and site data. I toggle off and 2 minutes later the toggle is ON to delete these upon data clear request.

  3. My location is showing on Google searches in Brave in spite of all locations services being off? With exception of Find my iPhone .

How can this issue be reproduced?

1.Try opening
2.reinstall on Ios 16.7
3.try toggles in ‘clear private data’ and see if they keep

Brave Version 1.58 ( Setup: iPhone, iOS 16.7, Brave 1.58
Library(215.9 MB)
Caches(34.7 MB) MB) MB) MB)
WebKit(28.3 MB)
NetworkCache(25 MB)
AlternativeServices(3.2 MB)
Chromium(2.7 MB)
Default(2.7 MB)
WebKit(112.1 MB)
WebsiteData(4 MB)
Default(2.9 MB)
ResourceLoadStatistics(1.1 MB)
ContentRuleLists(108.2 MB)
Application Support(68.3 MB)
Chromium(65.5 MB)
cdbbhgbmjhfnhnmgeddbliobbofkgdhe(2.4 MB)
aoojcmojmmcbpfgoecoadbdpnagfchel(13.6 MB)
phmomndefejccjmpiehbogokakkmnmgb(2.2 MB)
iiglahilpgmhlcogkkihklnbcjjgpddl(1.3 MB)
BraveWallet(10 MB)
femdbljnkmindcakmnbjhfefepeaicnm(1 MB)
jiajbjlakknofnkmlokcbanjbajpbdkl(1.1 MB)
hmnnhojoekmmehfpmeegehbmifiijobb(1.1 MB)
cffkpbalmllkdoenhmdmpbkajipdjfam(17.3 MB)
omoaeaghhgmiojkeaemjkpkmelmalbgo(3.7 MB)
fbljdmoohhbifebddjnbbljgencmpjlb(1.4 MB)
tmp(36 MB)
.com.brave.ios.browser.BevbR9(1.1 MB)
WebKit(24.3 MB)
MediaCache(24.3 MB)
.com.brave.ios.browser.1EwYIc(1.1 MB)

Mobile Device details. iPhone 10 , iOS 16.7

1 Like

Addendum: Cookies are not clearing . These cookies do not clear and are visible every time I open even private browsing, if and after I clear all data

@michal @fanboynz I’m not sure which direction to chase this on. I was going to create as an iOS issue but then as I tested, completely disabling Shields in SettingsBrave Shields & PrivacyTrackers & Ads Blocking to Disabled allowed the site to load. So it’s something screwy going on with Shields on iOS.

Switching it back to Standard or Aggressive causes the browser to immediately close/crash if the site is loaded.

I replicated this on Brave 1.58 ( on iOS 17.1

1 Like

Wonder if it’s specific to iPhones — while I do see a message telling me to turn off my ad blocker, the site does not crash with Standard or Aggressive shields enabled.

I cannot reproduce the issue with the private data toggles — on my end, I’ve toggled several options on/off, cleared the data and those options are preserved.

I do notice that you list v1.58 as your iOS Brave version but the latest release is 1.58.2. Wondering if it’s a typo or if you’re really pulling a previous build of the browser?

Also, @michal if it helps y’all, this should be the associated report with this last one.:

Client-2023-10-31-122737.txt (70.0 KB)

Not available on the app store. Only 1.58 is, at least on my iPhone.

@Mattches this made me second guess. So I went in and turned off all Content Filtering. Once I did this, it no longer crashed, even on Aggressive. I’m going to toy with it and see if I can discover which filter it is.

Very first filter I enabled again, EasyList Cookie seems to have done it.

I have since enabled everything else, which was Fanboy's Annoyances, uBlock Annoyances, Bypass Paywalls Clean Filters and it all loads with no issues. So it’s EasyList Cookie in particular causing it.

Sorry, should have tested all of that before concluding just Shields, but at least was in the midst of narrowing it down

1 Like

No worries — also I’m getting my version numbers all messed up. 1.58 is the latest build. I’ll let @fanboynz know about the filter causing the issue.

1 Like

I just downloaded from App Store ?

By every time I open App Store it crashes and restarts

It is easy list cookie that is the issue with mailonline- however my getting an older version of Brave when I deleted and downloaded from App Store today, seems to be a bigger issue. Any suggestions?

What do you mean? You have 1.58, right? That’s the current version. Mattches just had mistakenly mentioned 1.58.2

On line it states newest version is 1.59.120?

Something is not right , latest version is Not showing up on iOS?

@TheG that’s Wikipedia for you, whoever did it messed up. You can see they tried saying all versions were the same. iOS has always been different than the other operating systems.

Brave runs on Chromium for desktop and is also a chromium fork on Android. However, because Apple refuses to let anything other than Webkit exist on iOS devices, Brave wasn’t able to use Chromium base for it. So instead they did a Webkit version of the browser based off of Firefox for iOS.

This has always kept iOS versions to be a bit different. What’s interesting is they have used the iOS version as a testing ground for things they are thinking of implementing elsewhere. Such as how iOS version of Brave was the first to get Playlist, VPN, etc.

In any case, current version of Brave on iOS is 1.58.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.