Web.skype.com doesn't load

Skype web app stucks in loading screen

  1. Create a new microsoft account through hotmail.com
  2. Try loading web.skype.com Mine keeps stuck in loading like this
  3. it used to work great until last month
    image

It has to be a new account. My old account loads

Just checked on my end and was able to load the site without any issue. Have you tested visiting the site in a Private browsing window to see if you get the same results?

Hi Mattches. Have you created a new microsoft account? It still won’t load. I’m not sure why.
It works with my accounts that I created few months ago.

@Jaki,
Can you please try visiting and logging into Skype in a Private browsing window and tell me if you get the same results?

Thank you

Yes, unfortunately, it’s the same infinite loading of skype web app. Is this happening only to me?

I contacted Skype team too, and they said to clear cache and stuff but nothing worked, then said that I should use Edge but i can’t get it and even if I could, I would still want to use Brave

Same story here. It worked earlier this week.
OS: Debian GNU/Linux 12 (bookworm) aarch64
Host: Raspberry Pi 5 Model B Rev 1.0
WM: Openbox
DE: LXDE

@Jaki It’s definitely not the browser itself as I am able to login to Skype with my current account and a new one I made just for testing without any issue. I do have a few more things to try before logging this as a bug.

Can you (either of you) please try logging into Skype with Shields (lion icon in the address bar) down and see if this makes any difference?

  1. Visit web.skype.com
  2. Click the Shields icon and turn the main toggle “off”
  3. Allow the page to reset then try logging in normally again

Hey, I tried disabling shields, after seeing that it was infinite loading and the shield blocker was increasing (in blocking elements) and after some time I turned it off it finally worked.

After having it opened hours, it keeps loading and Brave is keep blocking the trackers. I’m not sure what’s going on.



image

Maybe the filter needs updating? I’m not using the latest brave browser because the chromium has an issue with the microphone (doesn’t work/detect it) on older windows 10 versions, which remains unfixed up to this day

@Jaki,
You’re saying that Skype does work when Shields are disabled? Also, what version of Brave are you on?

The first image it’s from Brave beta : Version 1.29.68 Chromium: 92.0.4515.159 (Official Build) beta (64-bit). it finally opened when i disabled shields. I’m using that version because it detects my microphone unlike newer versions (after 2021)
The second image is from
Version 1.57.62 Chromium: 116.0.5845.180 (Official Build) (64-bit)
It didn’t load even with shields off. and also now I’m experiencing another problem that didn’t happen before 2 days. The reddit comments won’t load. i refreshed, still nothing (but they load on beta)
It just shows this loading icon infinitely

@Jaki,
Going to be honest, these versions are both pretty old. I understand why you’re not electing to update but I would still highly advise you to do so. Not only for the variety of security fixes that you’re not privy to, but for the bug and site compatibility fixes that they contain as well. A simple update might resolve both of the issues you’re describing here.

:point_up: I would go back and turn Shields on but view the advanced controls and toggle each individual protection off/on until you find the offending protection. Do let me know which one is causing the issue.