Upgrade to Brave v1.45.123 appears to have broken Spaces extension

Description of the issue:

I have installed and used the Spaces extension since I first began using Brave about 6 months ago.

I just upgraded to Brave v1.45.123 and the extension no longer works. When I go to brave://extensions/ I see that Spaces is still loaded and not corrupted etc.

How can this issue be reproduced?

(With Spaces pinned to the address bar) click the “Spaces” icon and, from the dropdown", select “Manage spaces”. Nothing happens.

Expected result:

What should happen at this point is that Brave creates a new window that lists all the spaces available along with some options to backup spaces, etc.

Brave Version( check About Brave):

v1.45.123

Additional Information:

You can get to something that looks like the “Manage spaces” window if you select “Extension options” from the “Spaces” extension page under brave://extentions but you can’t open up an entire space from this window nor can you even directly click on any of the URLs listed in the spaces.

2 Likes

I also have the same issue; it appears to be fine with other browsers, but brave tends to be my go to.

2 Likes

Cannot access my brave rewards account

I tested Spaces on Chrome 107.0.5304.110 and it worked.

Also, on Brave, I verified that other Spaces functions like “Quick switch spaces” and “Move active tab” work. It’s jut the crucial “Manage spaces” function that doesn’t work.

I tested Spaces on Chrome 107.0.5304.110 and it worked.

Also, I didn’t know there was such a thing as the “extension console”. I’m having trouble figuring out how to access it. Is there a wiki entry or whatever that documents it?

@gpilz Any extensions that don’t work isn’t up for Brave to fix. You need to contact whoever is in charge of the extension and get them to check it out and make modifications. It works that way for practically any web browser.

Which, as I say that, I noticed you have posted under their support to say it stopped working. In the same token, you can also see other people are complaining. Such as:

Hopefully they will get to working on it for you.

1 Like

No one is going to tell me how to access “the extension console”?

This issue seems to have magically fixed itself in
version 1.45.133 Chromium: 107.0.5304.141 (Official Build) (x86_64)
.