Unable to fully login to Google Search on Brave

Description of the issue:
Similar to Can't log into google account - Mobile Support - Brave Community:

I am unable to fully login to Google using Brave. Note that, while i am logged in to youtube, gmail, google calendar and other services ; i can’t do the same for Google Search. Each time i access Google Search, i am logged out and greeted with its EULA popup. Clicking the connect button does a weird page refresh.

I tried disabling brave’s ad blocker as well as uBlock origin, then all my extensions, then tried through a private window, to no better results.
I also tried to click on the lock icon next to the address bar and remove all cookies and reset all permissions. it only allowed me to click the connect button, and actually land on the login page where I can put my login and password. But then, it leads me back to square one: logged off with a connect button that refreshes the page.

Here’s a reproduction of what happend on my side:

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Access Google Search while logged in.

Actual Result (gifs and screenshots are welcome!):
Being logged out of Google Search and unable to log in.

Expected result:
Be logged in.

Reproduces how often:
Any time i access Google Search

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 11
Brave Version 1.39.111 Chromium: 102.0.5005.61 (Official Build) (64-bit)

Additional Information:
You tell me :+1:

Can you test in private window mode? What are the shield settings? If it still fails, I would test in a new profile

Unfortunately, it doesn’t work any better in private windows nor with shield disabled.

Oh god… I checked the cookies and cleared them out many times… But completely ignored the “Blocked” tab! And sure enough:

I just allowed them and refreshed, and now I’m logged in. How did I miss that? Mystery…

Thanks for the help!

2 Likes