Unable to access FedEx Sign on since update

Description of the issue:
I have tried to go to the FedEx.com sign in page via bookmark and from the FedEx home page. The page starts to load but does not finish. The “form fields” to enter my username and password show up but the rest of the page does not load and nothing I do will allow the sign on to initialize. Have cleared cache, site data, and rebooted router. Page loads/works fine on other browsers and worked fine before updating to Brave version 1.49.120 Chromium build 111.0.5563.64

How can this issue be reproduced?
To be honest, I’m not sure if everyone has this issue or if it is only certain machines.

  1. Go to www.fedex.com and click on Sign up/Log in
  2. Click Sign up/Log in from the dropdown
  3. after clicking the second Sign up/Log in you should be taken to the page that doesn’t fully load for us.

Expected result:
page should fully load and we should be able to log in with our credentials
Brave Version( check About Brave):
Brave version 1.49.120 Chromium build 111.0.5563.64

Additional Information:
We tried clearing site data/cache in a few ways so if we are missing something, let me know. We used F5 and Shift+F5. We clicked on the padlock and deleted cookies from there. We also went into settings, privacy & security, site and shield settings, view permissions and data and then searched Fedex and deleted from there as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.