Twitter suddenly stopped working

Description of the issue:

Was retweeting and all and then suddenly, it kept telling me something went wrong but not to fret, try again. But wouldn’t let me post. I tried to save the tweet and it repeated the error. I finally clicked refresh and just get a big error page:

Closed and reopened the browser, no luck. Turned off shields, no luck. Cleared cookies and site data for the past hour, no luck. I haven’t restarted my computer yet because it’s a pain.

I tried checking Twitter’s status and on that page, it acted like I wasn’t logged in, asking me to log in with Google; my account isn’t associated with Google so I used the regular login link. Brought me to the same error page. I don’t even know if I’m logged in anymore or not. “Is it down or not?” sites don’t seem to be reporting Twitter problems.

Oddly, Twitter still works in Google Chrome (albeit clunkily), and in Brave for Android…so far. So it seems to be the desktop browser affected at the moment.

How can this issue be reproduced?

  1. Visit my Twitter account and try to do anything. All I get is the above message for any Twitter page. Refresh and Control+refresh do nothing.

Expected result:

See above.

Brave Version( check About Brave):

Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (64-bit)

Additional Information:

Maybe as soon as I post this it’ll start working again. ¯\_(ツ)_/¯

Oh for crying out loud. I only just noticed that big old link there saying “Log out.” So clicked it. It gave me some hassle logging back in but now I’m logged in??

I’m sorry, I seriously did not even see the big old button right in front of me. :roll_eyes:

While I’m here though, I notice there’s an “Install Twitter” link in the address bar, was that always there? It’s a bit annoying.

It probably has old cookies in the browser, try clearing the cookies, then re-login @tehuti88