TTS reads bookmark bar instead of page content

Description of the issue: macOS text-to-speech reads something other than the page content [multiple variants].
How can this issue be reproduced?

  1. Go to any web page
  2. Click before reading start point (optionally select desired TTS text)
  3. Press Option + Escape (or right click>speech>start speaking if text is selected)

Expected result:
System TTS should read the page/selected content.

Actual result:

  • if bookmarks bar is visible → “comma”
  • if bookmarks bar is invisible → “at; manage bookmarks; […each of your bookmarks from the bookmark bar (I think?)]”
  • EDIT Sometimes it will start reading from the address bar: “[url]; tor; ifs; vpn; at(?); manage bookmarks; […bookmarks list]”. I’m not really sure what makes the difference.

Brave Version( check About Brave):
Version 1.58.137 Chromium: 117.0.5938.153 (Official Build) (arm64)

Additional Information:

  • Current behaviour is consistent no matter what is selected or what kind of webpage I try it on.
  • Did not occur before update.
  • Have tried restarting Brave.
  • Have tried after turning off all browser plugins.
  • Have tried forcefully terminating AXVisualSupportAgent (macOS tts process)
  • AXVisualSupportAgent visually tracks correctly - it’s only the audio that is incorrect.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.