Truth Social STOPPED working

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

I have been using BRAVE for several months. One website that I have setup on the home page is for I have also been using the link for months. Suddenly today the link has been denied. I went to a different Browser and it worked perfectly. Therefore it MUST be a BRAVE BROWSER issue that I do not know how to fix. I tried the one recommended step of going to a private window setting on Brave but that did not work. what can I do to fix this?

I clicked on the link and it opened with no problem. Just in case, I also set it up as the page it opens to when I first open Brave and it loaded with no issues. Then I went and added it as a Top Site and it navigated with zero issues.

So I’m not quite sure what to tell you. I will say you need to provide all of the information that was requested of you, such as which version of Brave you’re using. Also which Windows OS you’re on?

When you say link has been denied, what error do you see? Can you replicate it all the time? Is the link you typed the exact link you’re navigating to?

This is the page that loads using Brave:

Truth Social is America’s “Big Tent” social media platform that encourages an open, free, and honest global conversation without discriminating against political ideology.

At the moment, Truth Social is available for U.S. users only, but rest assured, we are working hard to make it available in your country. When Truth Social becomes available for you, we’ll make an announcement. Stay tuned!

Access denied

You do not have access to

The site owner may have set restrictions that prevent you from accessing the site. Contact the site owner for access or try loading the page again.

  • Ray ID: 72ef5a1f7b7eadd7
  • Timestamp: 2022-07-22 21:43:27 UTC
  • Your IP address:
  • Requested URL:
  • Error reference number: 1020
  • Server ID: FL_509F67
  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.134 Safari/537.36

I use Windows 10.

Brave: 1.41.100 Chromium 103.0.5060 (Official Build) 64 Bit

I can access Truth Social on my Apple Iphone and I can access on every other browser, I just can’t access using Brave which is strange because I had no problem with it for months and then suddenly it will not load.

Jim Brown

Can you try just instead of and see if it makes a difference for you?

I know even clicking on the links you showed, it seems to work. But the converts automatically to the normal link as I mentioned.

For this to be said, along with everything else, they seem to be seeing you are outside of the United States. What’s interesting is when researching the IP address you shared, one of the places traced it to Atlanta, Georgia but said it was actually in Czechia (CZ).

Another site said your IP address belongs to Proton VPN but didn’t say much else. So I’m guessing you’re using a VPN? If so, do you actually live in the United States?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.