The connection to is not secure

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
Intermittant Warnings that connections to websites are not secure even though those websites do support https. I uploaded screenshots of typical errors to twitter.

How can this issue be reproduced?

  1. Turn on ‘upgrade connections to https’
  2. Turn on ‘always use secure connections’
  3. Type into address bar

Expected result:

Brave Version( check About Brave):

Mobile Device details
Android 10

Additional Information:

1 Like

Hello @Raven9

Thank you for reaching out and sorry to hear you’re having trouble with Brave. Could you kindly use guest mode to see if this behavior persists?

Be waiting for your response!

Not sure if it will make a difference, but you really do need to update your browser. Current version is 1.46.146. Your version was from around October.

The last time I updated was Nov 26 but I will update it again today.

I am using Android 10 I don’t think I have a guest mode

Make sure the date and time are exactly correct on your Android device.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.