Brave Android Making Unencrypted Internet Connections?!

Brave Android Makes Unencrypted Internet Connections!

If this an app coding problem, please have your devs FIX this ASAP, or tell me what to do if they can’t. I really like the Brave browser, Android and desktop, and I SURE don’t want to uninstall, but I have no choice but to disable it on my phone until you respond.

The particulars of this report are beneath this section. For a browser that touts how “secure” it is on my phone, Brave Android isn’t secure if it isn’t ALWAYS secure. Just ONE of these UNENCRYPTED CONNECTIONS is TOO MANY.

For your reference, four links talking about this app development problem will appear in a second post from me because your system only allows four links per post for new users? So you’re counting my 3 uploaded screenshots against my link total? There’s something else you could maybe fix, huh?


How can this issue be reproduced? I can’t reproduce it, and I can only track it when Brave decides to do it. To track these connections, I use the diagnostic Android app called “AppSnitch,” available in the Google Play Store.

Expected result: Well, I EXPECT Brave to ALWAYS connect to EVERYTHING on the Internet securely, but your browser has apparently put my phone security in jeopardy by making 3 UNENCRYPTED connections in the last 7 weeks using TCP protocol via Port 80 with an HTTP service to:

  1. a Web Werks server registered in Philadelphia,
  2. a WPEngine server registered in Texas but apparently located in Spain, and
  3. a Cascade Networks server registered in Washington state on behalf of a website I visited.

Again, just ONE of these UNENCRYPTED CONNECTIONS is TOO MANY.

Brave Version( check About Brave) Oh… so it’s in Settings, thanks. Brave: 1.16.76, Chromium: 86.0.4240.198.

Mobile Device details OS: Android 9 (moto G6 play), Build: PDPS29.118-67-10.

Additional Information: I uploaded 3 screenshots, one for each of these connections I’m reporting, but your posting system will only show the first two. That’s still enough to see the problem:

201116-SS-01|250x500

[END]

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.