The Browser completely broke

Description of the issue:
My browser suddenly doesn’t load any pages properly anymore. All the images, text, and most other visual elements suddenly dissappeared. I can still interact with the webpages themselves, but they show next to nothing on them. Even the brave menus and setting pages have this issue. The only visual element that seems to be working are video players.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
I have no idea how or why this happened. It just started happening today after I downloaded the latest windows update the day before.

Actual Result (gifs and screenshots are welcome!):

This is what my youtube videos look like now.

A different example of how broken webpages look

Attempting to access the settings page

Expected result:
I was hoping that my pages would load properly

Reproduces how often:
Every page I visit is like this

Operating System and Brave Version(See the About Brave page in the main menu):
I have a windows 10 machine and am running the latest version of Brave.

Additional Information:
The header (tabs, url bar, mini menu in the top right, bookmarks, etc,) Are still visible and seem to be working fine. Only the pages themselve are completely broken

1 Like

@Fighting_Planet short version is:

  • Usually things like you’re showing are because of bad extensions

  • It can also be because you’ve decided to do things like Block Scripts on Shields settings or have some custom filter you’ve added that’s causing issues.

  • Lastly, have you tried clearing cookies?

Part of the common steps to test would be:

  • Open in a private window. Does the issue go away? If so, it’s 99% an issue with an extension.

  • Create a new browser profile. Does the issue go away? If so, it’s your settings or an extension.

I have a similar issue on mobile. I don’t think it’s extensions (are there extensions on mobile)? I will start my own thread, but my suggestion to OP is to maybe try and toggle some of the GPU flags brave://flags and search for GPU. Or maybe try toggling vsync or AA settings in your nvidia or adm control panel. Lastly, see if the issue persists in Chrome or Firefox – then you know it’s a Brave issue and not a hardware issue.

@Saoiray the issue still persists when I try both test steps. I haven’t touched my shield settings since I installed the browser. Also I can’t access my cookies settings since the issue also happens on my brave settings screen.

@nasch007 I don’t know how to toggle flags. can you maybe provide a more detailed explenation on how to do that?

Hmm, ok. And if you download again from to essentially do a manual update, does anything resolve?

@Mattches any thoughts?

I’m not sure how I can be more detailed than I was? Go to URL brave://flags and then search for GPU. Try toggling flags one at a time and restarting the browser: i.e., if it was off, turn it to on, restart. If it was on, flip it off, lather rinse repeat. I would do one at a time and just see if any make a difference.

In the past I’ve had issues with nvidia MFAA, I’m not sure what your setup is as you haven’t detailed, but if you have an nvidia GPU it may be worth adjusting the profile for Brave.exe. Try disabling any vsync or AA related settings and slowly enable them until it comes back.

Don’t do both of these (change gpu flags and nvidia/gpu settings) at the same time. Do them separately to know what change you’re making is affecting the issue.

I have already attempted to manually update the browser using the latest download. I even attempted a full reinstall of the browser yet the problem still persists

1 Like

Also after downloading another windows update some of the visual elements seem to have come back. Most text elements are now visible again. however images, icons and some other css elements seem to still be missing

1 Like

Can you please try going to Settings --> System and disable the Hardware Acceleration setting here, relaunch and check to see if the issue persists after this?

Thank you

same thing happened to me today. I have tried to fix and nothing works. I am making this post thru fire fox.

Thanks so much! the browser works perfectly again.

So does the problem occur due to an issue with my hardware?

again thank you so much for solving the issue.

Nothing wrong with your hardware — it just isn’t jiving with that particular setting. You should be good to go now!

@Fighting_Planet let me try to clarify really quick. Use hardware acceleration when available means that your device will try to use your graphics card (GPU) instead of your CPU to run some tasks. This eases the burden on your device and it usually runs more smoothly.

That said, a variety of graphics settings could cause issues. Or if you have a low quality graphics card, sometimes it can’t handle the demand. I guess the big thing to do if you see that disabling Hardware Acceleration resolves problems is to check for updates to your drivers and then check all the settings in your graphics, especially for anything pertaining to Brave. Heck, maybe even just putting it all back to default might resolve.

But in any case, it just means your graphics card and/or graphics settings aren’t friendly with Brave and that’s resulting in your issue(s). You can either experiment with settings and try to resolve or you can leave it disabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.