Suddenly getting YouTube ads?

I strongly recommend trying Ublock origin.

I have used Brave for about 1 year religiously as my main browser after trying it off and on for while and I have never had a youtube ad. Anytime I install/reinstall windows I have a list of programs that I will install immediately and the first thing I do after installing updates is use Edge to install other browsers and then install Ublock origin.

Just my suggestion is all.

Actually uBO is also having issues. Its not a “Brave issue”, Youtube is clearly trying new methods.



2 Likes

Really can’t watch Youtube on my mobile app of Brave atm, it’s ridiculous what youtube are doing being so aggressive here. I’ve had to use adblocker browser but even that displays ads on the home page of YouTube, but removes them from videos. It’s just a little slow using that app. Hopefully Brave can fix this soon

Every 24-48 hrs., I believe.

1 Like

Same problem here. Resetting permissions and cleaning the cache didn’t help.
I think we have to fight YouTube, right? :wink:

If you’re experiencing Ads, test in Brave Beta (Trackers/Ads = Aggressive-mode in Shields for youtube.com) as test. A few people have confirmed better luck with youtube ads in Beta

1 Like

What about on mobile? Can you get a brave beta app? Because Youtube is unwatchable on my mobile right now because of the ads

There is Brave Beta on Google Play…So you could install it…

Tried it and it didn’t work as I’m still getting ads on my mobile app. Really sucks tbh so I’ve uninstalled brave until this is fixed. Using free adblocker browser for the time being as it at least works on stopping ads playing. Not so much on displayed ads on the pages but at least I don’t have to suffer them played

Here with last update
[Versiunea 1.10.90 Chromium: 83.0.4103.97 (Official Build) (64-bit)]
Still receiving ads in YouTube…But now I can skip them…It is better…Until this problem will be resolved…If will be resolved…because Google does not want to lose so much money from ads…

Just saw my first ad this morning on YouTube. Brave up to date. Shields up. Will try the suggestions.

I just saw my first add on youtube using Brave today.
I never saw an add before and did not change any ad related settings recently.
Shields are all up.
I’ll try suggestions.

YouTube have made some dramatic changes now, that cookie hack that I posted the link to early in this thread that forces YouTube to use the old layout no longer works as of today and if using adblockplus, adblock ultimate on desktop every second video will give a “An error occurred. Please try again later. (Playback ID: random letters and numbers)”, I believe this message stays for as long as the ad was suppose to play for, very annoying.

I came here too for the same issue. I seems to be successful by installing Ublock and setting the protection only on the YT site (options). I then disable ads blocking for YT in Brave and let Ublock handle that site. So far adds are gone. (desktop version)

I made an account just for this issue. As of two weeks ago, I can’t block ads on YouTube. Yes, shields are up. Yes, I cleared cookies and cache. I’m not a tech illiterate tard so don’t even ask. I had used this brave browser for Android app specifically for YouTube, and even had it set to the mobile website for my homepage. Saying “it’s a YouTube thing, not brave” is an absolute cop-out. It’s funny, no one who uses browsers with AdBlock and NoScript seem to have this issue. People with UBlockOrigin don’t have this issue. I’ve supported brave and beta/alpha tested it for years, only to see it become a massive failure. Either this issue needs fixed or I’ll go find something superior because when you say it’s YouTube and not brave, you’re just proving the major tech firms have evolved beyond the capacity of brave. Either brave should evolve or it’ll go the way of the dinosaur, too. What a massive pile of crap.

Like I said YouTube are trying their hardest to make these adblockers worthless, at the momment using adblockplus or adblock ultimate I am getting a lot of Please try again later. (Playback ID: random letters and numbers) and the video won’t load for 30 seconds or a minute, I believe it is for as long as the ad in suppose to run. After that period the video will automatically load. I will now try UblockOrigin but won’t hold my breath. If this doesn’t happen to you it just means YouTube hasn’t updated for you yet, they roll out updates gradually, some people instantly, some a week later.

Was also irritated by getting ads with Brave on Youtube lately. :smiley:

But I’ve found some kind of “Workaround” - or at least a possibility to skip the ad manually:

  • Start video, ad appears
  • open BraveShield -> activate script-blocking -> deactivate script-blocking
  • ad is gone

At least on desktop this seems to work.

As soon as I see ads I reload page and it doesn’t appear again

1 Like

Reloading the YouTube page works…if you’re not also running the AutoplayStopper extension because Brave no longer prevents videos from playing automatically.

FYI for the devs, I started seeing ads on YouTube a few days ago, and on Google today. I’m sorry to say, I don’t have the time right now to try the beta.

I see ads on YouTube starting page but not while watching videos on brave for Android