Suddenly getting "Error code: SIGILL" on many websites

Description of the issue: Suddenly getting “Error code: SIGILL” on many websites
How can this issue be reproduced?

  1. Visit or

Expected result: I expect the pages to open instead of showing the error

Brave Version( check About Brave): Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)

Additional Information:
I’m on Ubuntu 20.04
Today I started getting this error on many pages.
Rebooting, clearing cache and cookies and opening the page on a private window doesn’t help.
Other browsers work perfectly fine.


Getting exactly the same error on Fedora 37. Cannot open any page including about or settings.

The latest linux release of Brave seems to be completely broken.


Same issue here, page loads for a second before the Sigill error code pops-up.

Tried disabling extensions and clearing cache and cookies. No Luck.

Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)
Ubuntu 22.04.2 LTS

Did a clean install using curl and the “new” Brave seems to be working.

1 Like

Same problem here after updating on Fedora to version brave-browser-1.50.121-1.x86_64.
Running remove and install through DNF sequentially does not work for me (settings remain intact so perhaps it’s related to some settings, or sync which I did have enabled).
Can’t open any webpage or internal pages such as settings.

1 Like

Same here after update. I’m on Fedora 37… :frowning:

1 Like

It may be a more general chromium issue, as I tried the latest version of Microsoft Edge as well and it is having the same problem with exactly the same error code.


I can’t say what the problem exactly is, but I have a possible workaround.

System Info:

OS => Fedora Linux 38
Kernel => 6.2.11-300.fc38.x86_64

Brave Browser Info (Crashing):
Version: 1.50.121-1


On fedora, we can just downgrade the brave-browser package.
With dnf --showdubplicates list brave-browser we can look which packages are cached.

My output:

[root@thinkpadx395 ~]# dnf --showduplicates list brave-browser
vscodium-repo-rpm                               1.1 kB/s | 866  B     00:00    
Installed Packages
brave-browser.x86_64        1.50.121-1         @brave-browser-rpm-release_x86_64
Available Packages
brave-browser.x86_64        1.48.171-1         brave-browser-rpm-release_x86_64 
brave-browser.x86_64        1.49.120-1         brave-browser-rpm-release_x86_64 
brave-browser.x86_64        1.49.128-1         brave-browser-rpm-release_x86_64 
brave-browser.x86_64        1.49.132-1         brave-browser-rpm-release_x86_64 
brave-browser.x86_64        1.50.114-1         brave-browser-rpm-release_x86_64 
brave-browser.x86_64        1.50.119-1         brave-browser-rpm-release_x86_64 
brave-browser.x86_64        1.50.121-1         brave-browser-rpm-release_x86_64

The last entry is green on my side – this means it’s the one which is installed right now.
You can then install a package/upgrade earlier with dnf install brave-browser-1.50.119-1 in my case. The dnf package manager tries then automatically to downgrade the brave-browser package.

Now brave-browser does work again, and we just need to wait until a fix is here.

For the next system upgrade via dnf add dnf up --exclude=brave-browser to your command. So every, package gets updated except brave-browser until we know the new update will work.

I hope I can help with this to bridge the wait time until a newer update is here.

Greets LxWulf


@LxWulf Thank you for the workaround.

I have the same system info:

Kernel 6.2.11-300.fc38.x86_64
Fedora 38
Brave 1.50.121-1

And Brave is now crashing on almost every page since that last update.

1 Like

No problem, happy to help. :blush:

It was the same situation on my side until I downgraded brave-browser as described.
I even now write those words in the downgraded brave-browser. :grin:

1 Like

I’m not sure if it’s related but I’ve noticed a System Failure right after logging in GNOME and that includes brave in its output.




traps: brave[3395] trap invalid opcode ip:55cacfef690c sp:7ffd4236fb80 error:0 in brave[55cacbb05000+aefe000]


BOOT_IMAGE=(hd1,gpt5)/vmlinuz-6.2.11-300.fc38.x86_64 root=UUID=1eab5243-85b2-4778-b86f-36f0a7b1c593 ro rootflags=subvol=root rhgb quiet

More importantly, here’s the cmdline that generated the error with reason brave killed by SIGILL that I got from GNOME Problem Reporting:

/opt/ --type=renderer --crashpad-handler-pid=14251 --enable-crash-reporter=, --origin-trial-public-key=bYUKPJoPnCxeAvu71j4EmXuK7tr1PBC7SHh8ld4Mw3E=,fMS4npO6auLR/QNd+zKmxzoy/VR6B1EUTqoCW04ztRU= --change-stack-guard-on-fork=enable --brave_session_token=7126019843103326652 --lang=en-US --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=6 --time-ticks-at-unix-epoch=-1681998254587908 --launch-time-ticks=3999837410 --shared-files=v8_context_snapshot_data:100 --field-trial-handle=0,i,18125051776039769189,7978106451523140309,141872

I disabled all the extensions and restarted Brave. Solved the issue on my end.

Will try to narrow down to which extension(s) are impacting the browser.

Started Brave with the command line “brave-browser --disable-extensions” to see if it was an extension causing the problem, but Brave still had the ‘sigill’ error, so not sure it is an extension issue.

1 Like

Thanks all for reporting. The team has identified the issue3 and is working to release a fix, expected within the next few hours.


Same, fedora 38

Glad there’s already motion. Adding dmesg spew just in case ( too new to upload files ):

Apr 20 11:59:10 tigre systemd-coredump[23110]: Process 23037 (brave) of user 1000 dumped core.

                                           Module /home/[redacted]/.config/BraveSoftware/Brave-Browser/WidevineCdm/4.10.2557.0/_platform_specific/linux_x64/ from rpm brotli-1.0.9-11.fc38.x86_64

The fix has been released with Release Channel 1.50.125 (Linux Only)


This release has been fixed the SIGILL error code. Thank you Brave staff.

Fixed the problem on Fedora38, thank you!

Same here on Federa 37.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.