Error Code: SIGBUS (7) occured two times while writing Email. Never occured before or afterwards. Using newest Brave version

Description of the issue:

Like the title describes I had two times in a row the error code: SIGBUS (7).

It occured when I was writing an email (outlook / office dot com). I tried reloading the page but nothing happens. I closed brave browser.

As I tried to open brave browser by clicking the symbol it shows the “linux mint loading cursor” but does nothing. I then looked in System Monitor and ended the brave task.

Then I tried to write the same email and after a few seconds after I wrote the “Email title” the website didnt respond and the same error occured. My System however wasnt lagging or so. It was working fine.

So after that I tried another time, hoping to get the same error, but nothing happens. I was able to write my email. No error code occured. All works fine.

Regarding my question: Why does this error occur? What does the error mean? Does that error occur much or do have other users had this error before? How could the error be fixed - Is it random, as the error occured two times in a row but not anymore?

I have no extensions installed. I have only activated the brave shield with:
-Easy list cookies
-Fanboys annoyances
-ublock annoyances

Except the day today all worked fine in brave. I even did not had the error code as I wrote my email yesterday. The error also never occured while watching youtube or browsing.

I only used my system for writing documents and playing low end games from the linux mint software manager (both system packages and flatpak packages).

I never downloaded anything or went to websites. The only websites were like youtube, online stores, linux forums and email.

My system has enough free space and ram.

Ive already sent the crash reports that are in “brave//crashes”.

How can this issue be reproduced?

1.Issue occured while browsing (especially resource hungry websites like email/office I think (thats the only thing I know how that issue occured. Now I cant reproduce it…No error occured after that)
2./
3./

Expected result:
Error code: SIGBUS (7)

Brave Version:
1.62.156 Chromium: 121.0.6167.139 (Official build) (64-bit)

Additional Information:
-OS: Linux Mint Debian Edition 6
-Up-to-date system (update manager)
-installed the system only a week before

-System: CPU: i3-3217U / RAM: 12GB DDR3 / SSD: 128GB

1 Like

Thank you for the highly detailed report — really appreciate it.
I do think this is a Linux specific issue and it’s likely intermittent. I’m going to ask some of our Linux folks about it — in the meantime please let me know if the issue occurs again.

Can you also please share the crash report IDs from brave://crashes so I can pass them onto the team as well?

Im very sorry for the late reply. Do you mean only the crash report ids or the whole site (brave://crashes) as a screenshot?

Thanks for the fast reply though :slight_smile:

Crash report ID 1: f63e0000-8de4-790b-0000-000000000000

and

Crash Report ID 2: bd550000-8de4-790b-0000-000000000000

@newby80,
We think that it is likely this issue that you’re seeing:

Team is already looking into it

1 Like

Thats interesting.

I didnt updated Brave since the issues and cant reproduce the problem as it is described in the github article.

Also the issue only occured 2 times in a row (there was not more than 1 hour maximum between those 2 issues) on the same day.

The days before all worked fine. Also there was no problem after that 2 issues.

Also now everything works fine.

The only site I was using was office dot com for email writing. When I did that, after about some minutes of being AFK while having a email open (That I have started but not ended writing), the error occured and I had to close brave.

I also had to close brave in the system task monitor.

After that I tried that email thing a second time and the same error was displayed. Short before that I tried to write a text in the email and the UI of office dot com didnt work anymore (trying to click buttons etc).

After that I tried it a third time and everything worked fine.

So I dont know what the error was. So what I understood what the “sigbus (7)” error was, it could be something that the memory was too low for a task. But I have available plenty of memory. 12 GB and not much used / allocated / reserved. I also have a 12 GB swap partition and enough of System Storage space left.