Steamcommunity.com login page can't load scripts

Description of the issue: https://steamcommunity.com/login fails to load scripts. Error:

jquery-1.11.1.min.js?v=.isFTSRckeNhC:4 Refused to load the script 'https://steamcommunity-a.akamaihd.net/public/shared/javascript/crypto/jsbn.js' because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-inline' 'unsafe-eval' https://community.cloudflare.steamstatic.com/ https://api.steampowered.com/ https://cdn.cloudflare.steamstatic.com/steamcommunity/public/assets/ *.google-analytics.com https://www.google.com https://www.gstatic.com https://apis.google.com https://recaptcha.net https://www.gstatic.cn/recaptcha/". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

There are two of these, one for jsbn.js and one for rsa.js. This makes it so I cannot log in at all, RSA is not defined and thus it’s loading infinitely. This does not happen in Microsoft Edge or IE. This also doesn’t happen in a private tor window, however a regular private window didn’t work either. I have tried clearing my cookies and cache to no success.
edit: I also tried shields down, that does not work either.

Steps to Reproduce (add as many as necessary):

  1. Head to https://steamcommunity.com/login
  2. Hit F12 to open the console
  3. Observe the aforementioned errors.

Actual Result (gifs and screenshots are welcome!):

Expected result:
The scripts load fine.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Home, 10.0.18362 Build 18362
Brave v1.11.104 (latest at time of writing).

can you disable all extension

Same errors in the console.

it work here fine but under linux

so what about new profile ?

Tried that too, didn’t work either. I was able to log in before just fine, and I can log in on store.steampowered.com just fine too (I assume they use the same logic).

ok i will ask @Mattches help he is a team member

please notice it weekend so maybe you get your response tomorrow

hope he fix your issue and have a nice day both of you

i do not get error even i use the aggressive and strict settings
so let us wait and hope Mattches help you :slightly_smiling_face:

Hey @lieuwe_berg what are you trying to do? Logged into (and logged out) my steam profile without issue (Make sure you’re not blocking scripts in shields)

1 Like

just my tiny thought
@fanboynz

@lieuwe_berg said it work on tor browser so i think it’s cdn server in cloudflare side block for his ip

so i think he has to test it using different device maybe his phone while connected to the same network his laptop/pc connected to the internet like same wifi and see if it work or not or use different browser on his laptop/ pc and see if it work or not

if it still has the issue then check if he connected his phone to the mobile data and see if it work

hope that help and have a nice day

From the original post:

This does not happen in Microsoft Edge or IE.

I can go directly to the script just fine (https://steamcommunity-a.akamaihd.net/public/shared/javascript/crypto/jsbn.js), so I don’t assume it’s a cloudflare block.

Edit: it seems that after logging in through the steam store and navigating to ‘Chat’, it brought me to steamcommunity.com/chat and recognised I was already logged in on the store, storing my credentials for steamcommunity.com too.

I can successfully reproduce this workaround. If anyone else is struggling with this same issue, do as above.

Does shields affect it? @lieuwe_berg

oh sorry my bad did not notice that and thank for explaining :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.