Some Websites Not Showing

I run into websites where most of the content first loads and then disappears. If I click ‘Esc’ right after the site has loaded I’m able to see the content. This happens fairly often, and I have been using the report-a-broken-link-button quite a lot, but now I’m wondering if there’s something wrong with my setup rather than Brave.

My most recent example is this page:

I have fairly strict shield settings, but this also happens with shields down.

I use Brave version 1.22.67 (Ubuntu 20.04). This doesn’t happen in Chrome.

Any ideas what could be going on?

Edit: I think it could be related to websites that have embedded videos.

I believe what is happening is that the browser is blocking this overlay you see here:

This overlay is blocked and produces some weird results – but also explains why hitting Esc fixes the site. Because all you’re doing is closing that overlay window, you just can’t see it. This is likely something to do with the way your Shields are set up. I would recommend clearing cache/site data for the sites you see this behavior and see if this changes anything.

Can you also tell me what your Shields settings are set to?

1 Like

Blocked overlay in Fanboy Annoyances via brave://adblock (in the next 24-48hrs)


Wouldn’t that only happen with shields up? It seems like hitting Esc cancels some job that would otherwise render the page invisible. If I click Esc after the page has finished loading, nothing happens.

I tried loading the page with and without Fanboy Annoyances List ticked (cleared cache), but no difference.

Did you try clearing cache/site data? Also, do you have any browser extensions installed at this time?

Only one extension, but deactivating it doesn’t help.
I’ve tried clearing the cache to no avail. It also happened the first time I visited the site.

I’m sorry you’re having issues with Brave; but I’m glad I’m not alone. After a recent SSD hardrive change I find that my previous favourite sites simply do not work. Being very reluctant to use Google Chrome (where all of my favourites are stashed; I’m a little stuck. Can anyone help?

What’s one of your favorite sites? I’ll see it if works for me.

I don’t see any reason why this should be the case for you – on my end, I’m able to visit and browse the site without issue. Can you please try creating a temp. browser profile and visiting the site using it? I’m curious to see whether or not you get the same behavior.

Also, do you have any other examples of sites that won’t load?

We’re getting somewhere! The test profile loaded the page without issues. Any idea what could be wrong with my profile?

I don’t have links to pages with similar issues, but will remember to add any here, that I come across, if that could help solve the problem.

I think you may need to clear your cache/browsing data for All time in the Clear browsing data menu. Something is locking the site up but its hard to tell what it is – often times clearing data will shake loose the stuff that’s stuck. This is why it works on your other profile – because whatever data is “stuck” isn’t present in the newly created profile.

I tried clearing all browsing data, but the issue remains in my main profile.

Hmm – well it’s clearly whatever the difference between the two is. Can you visit the site and open dev tools (Menu --> More Tools --> Dev tools) and send a screenshot of the Console tab in the dev tools window?

Sure. This one?

Yes that’s perfect. I have one last thing to check – can you go to brave://adblock and see if you have anything listed in the Custom filters section of the page?

I appreciate you taking the time to help.
Nothing is checked or listed there.

Hey, can you paste the blocked items listed in the shields Ads & trackers ?

From your screenshot, there are blocked items to domain which I’m not seeing. Also, if you access a VPN, can you try from a different location to see if it makes a difference.

Good point about the VPN. I turned it off but same result.

I see slightly different readings this time. Here are the two unique errors I get now:

What I’m seeing in shields