[Solved] Brave Logo appears on screensaver

I use Linux Mint with Cinnamon desktop. Currently running brave version 1.60.118. All of a sudden in the last few weeks every time my computer goes into screensaver there is a brave icon logo on the screen. I can find no setting to disable this. Please explain.

1 Like

Hello @mdarbygr

not sure if the following is the cause or not

  1. does this happen if brave opened before the screensaver start or that happen even if you close brave

  2. could you make sure that brave not working on the background go to brave://settings/system and make sure to uncheck Continue running background apps when Brave is closed option

hope that help and have a nice day :slight_smile:

1 Like

This is a very strange sounding issue. I wish there were a way I could see how it appears on your end.

To be clear, this is not a “feature” or “setting” — there is some sort of bug happening here.

2 Likes

@mdarbygr is there a way you could take a picture of this and share? I know screenshot might not be able to be possible, but perhaps picture from your phone or something?

Guess also curious, if you change the screensaver you’re using, does it happen there? If not, does toggling back to existing screensaver continue to do this?

1 Like

The image appears a couple seconds after the screensaver turns on, and moves around the screen every few seconds like it’s a brave specific screensaver. It seems to have appeared about when I recently upgraded to 1.60.11. Brave is a
flatpak, which seems even more confusing to me.

1 Like

How did you upgrade? And where did you initially download from?

Guess part of me is wondering if you might have gotten an unofficial version of Brave or something.

Also tagging @Mattches back in so he can see it since he mentioned would have liked to see what it looks like from your end, just in case he might recognize anything based on what you’re showing. But definitely isn’t anything I’m aware of being available through Brave and is kind of sounding some alarms in my mind.

So yeah, knowing where you downloaded from and how it was updated might help figure out a bit more of what’s happening.

1 Like

brave on flatpak is not official

NOTE: This package is not verified by, affiliated with, or supported by Brave Software.

so try to download the official one from

It’s the flatpak from the linux mint official repository. Why they would do this is confusing, but I’ll definitely try direct download.

every linux dist add their flavor but from the official mint repo

i do not see brave package there but i guess they use flatpak to get the other missing package

i did not use mint before so i have no experience about the customization there

@mdarbygr
Please let me know if the official version fixes the issue.

I replaced the flatpak with the official version. I thought things were fixed, but today, I saw the logo again. It goes away if I force kill the primary brave process. I don’t understand how any website should be able to affect the screensaver, but it seems inconsistent like it must be something on one of my tabs or extensions.

if that mean it show up if you left brave running then to make sure that brave shutdown after you close it then do the following

my guess that there something related to the screen saver or notification of the os that make show up icon of running app or maybe when that app get a notifications

so it more likely to be os configurations

Finally figured it out. Today the image on the screensaver turned into the thumbnail on a YouTube video. It turns out the new version of Linux Mint Cinnamon defaults to show “album art” cover for playing media on the screensaver. For some reason, when certain tabs are open in Brave it picks up the brave logo as the album cover of playing media. Showing this on a lock screen or screensaver is dumb, but at least you can turn off the “show album art” toggle on screensaver settings.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.