Solved: Brave browser commandline switches don't always work in Windows 10

Windows 10.0.19042 build 19042 (20H2) x64 enterprise, latest Brave build!

All commandline options except for the commandline to enforce TLS 1.2 " --ssl-version-min=tls1.2" works. It will work only if I right click the taskbar shortcut, click properties, and close the shortcut properties window, without even changing the commandline syntax. Very strange. Even when I do edit the shortcut and brave successfully loads the commandline, minutes after closing the browser, the problem returns, same upon reboot. Update: it appears it may not be necessary to edit the shortcut, it will stop working sporadically regardless.

You can test this for yourself here, https://clienttest.ssllabs.com/

To recreate, just add the commandline I use, and test your browser on the aforementioned link after reboot and sporadically.

"C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --ssl-version-min=tls1.2 --cipher-suite-blacklist=0x009c,0x009d,0x002f,0x0035,0x000a,0xc00a,0xc009,0xc013,0xc014,0x33 --disable-webgl --safe-plugins --enable-sandbox

Note cipher suite blacklist always works, regardless if enforcing tls 1.2 does or does not work.

1 Like

perhaps this is a cache issue and the test is not running on the website properly, ill look further into it.

I believe this is a cache issue; other websites report that only tls 1.2 and 1.3 are enabled; while ssllabs reports incorrectly.

1 Like