Site comments no longer loading

Description of the issue:
I use zerohedge,com for news and financial updates. Up until today, the site has always worked well in Brave. Indeed, all the ZeroHedge community members recommend using Brave so that we do not have to be subjected to all the publicity the site displays. As of this morning, the comments at the base of any article will no longer load although they do when using any other browser other than Brave or Chrome.

I opened Brave and Chrome on my PC and the problem exists there too.

Steps to Reproduce (add as many as necessary):

  1. Open any article on, scroll down to the end, and the comments section should automatically load, but it won’t. This problem may apply to other forums/blogs as well.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Comments section will not load.

Reproduces how often:
All the time with all articles.

Brave Version(See the About Brave page in Settings ):
1.1.2, Chromium 75.0.3770.143

Mobile Device details
Samsung Galaxy Tab A

Android/iOS Version

Additional Information:
Same problem happening in Windows 10 with Brave version 0.66.101 Chromium: 75.0.3770.142 (Official Build) (64-bit)

Changes to Brave are the cause of this issue. If one turns off blocking of 3rd party trackers, the comments section works again, but all the ads return as well. I can see no option to unblock individual 3rd party trackers in order to restore site functionality.

This problem only began today and comes hot on the heels of the last problem I reported, Brave not responding to clicked notifications.

As both worked perfectly before, it would appear the development team have broken it, and why is it not possible to enable/disable individual scripts and trackers as with NoScript, Adblock, and Ghostery?

1 Like

I am having the same problem on my PC and am getting EXTREMELY mad with it. I tried to change the settings like you did and the ads etc were ridiculous and ruin the site.
I verified in Firefox and the comments section came up. So it definitely is a Brave problem.

WHEN will Brave fix this???

I’ve fixed in Easylist, fix should show up in the next 24-48hrs.

Problem fixed. Thanks

It is fixed on the PC version but not on Android.

Still not working in Android and no replies.

Just tested Brave (1.1.2) on Android, Comments loaded fine. no issues here.

Not working here. What do I need to do to make Brave update itself with the change you made please?

Could re-install I guess? clear app clache/settings and let it re-load.

How do you clear app/cache settings, please?
I’m sorry if the question sounds dumb but I don’t have a smartphone and I’m pretty much a beginner where my tablet is concerned because it doesn’t operate like Windows.

This topic was automatically closed after 30 days. New replies are no longer allowed.