Site-Blocking reflects censorship

#1

I am an early adopter of Brave. In the past couple of weeks, you have started blocking Breitbart, Gamestop, Mallard Fillmore and the Vikings Official Site among others which reflect badly on non-conservatives. I suspect this is because of your reliance on
Spam404 and Disconnect.me. You have had a good product, but this censorship obviates your stated goals. Fix it or lose me.

#2

Hi @Clydelo,
this is not Brave’s fault, you are likely still running the old Muon version, which had this issue for a couple weeks now. There was a big upgrade months ago that you probably missed.
If you go to Brave > About and it says “Muon” instead of “Chromium”, then you need to go to brave.com/download and install the latest release. After that, future updates will be possible from inside the Brave UI again.

1 Like
#3

I can access those sites with no problems here.

Version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit)

#4

I definitely think @BraveNew and @yubi are correct here; it sounds like you’re using an old and outdated version of our Muon browser (likely version 0.25.x or or 0.26.x). If this is the case, you should update immediately. Note that this version of Brave may wrongly claim to be the most recent, and fail to offer an update. Manually updating is almost always necessary in this event.

2 Likes