Share link works on one Mac, but not Mac

I have Brave set up on two of my Macs, an iMac and a Macbook Air. Both are running Mohave.

On my Macbook, when I pull down the File>Share menu, there is an “Email Link” option, with a Brave icon on its left. When I use it, it brings up a Gmail send screen. Works. On my iMac, it does not work. I can get to the “Email Link” menu, but then nothing happens after selecting it. I have Brave set as my default browser, and Brave set up in Mail as my default email client, same as on my macbook where it works.

Any idea why it’s not working?

Mac version: Mohave 10.14.4
Brave: Version 0.63.48 Chromium: 74.0.3729.108 (Official Build) (64-bit)

Thanks for reaching out!
Seems strange that this isn’t working on one mac but is on the other :thinking:
Are you signed into your email account on the iMac?

Yes, I am signed into gmail.

Can you check Settings --> Advanced --> Privacy/Security --> Site Settings --> Handlers
and see if gmail is listed here?

It’s there, but it’s blocked. So I clicked the X to remove it, but now I don’t know how to add it as in your screenshot.


Simply visit and, once logged in, it should prompt you in the address bar as to whether or not you’d like it to be your default handler for emails:

Awesome! Thanks so much.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.