Brave email link stopped working

I updated to the latest Brave version for the Mac desktop today. Now the File > Share > email link feature isn’t working. I see a Brave icon next to the “email link” option, but nothing happens when I select it. It usually opens a new message in Apple’s stock Mail app, but the selection doesn’t appear to do anything now. I’m running Monterey on a 2019 MacBook Pro 16-inch. Here are the Brave version details: Version 1.49.132 Chromium: 111.0.5563.147 (Official Build) (x86_64)(

Hello @lastgasp

Thank you for reaching us and I’m sorry to hear you are going through this. Please try creating a new profile by going to main menu > create a new profile , to see if the issue persist.

Be waiting for your response!

Hello and thanks for your reply. I created a new “bughunt” profile and see the same behavior with it. I select “Email Link,” but it doesn’t appear to do anything.

Hello. I’m replying to keep this bug report active. I miss the share email link functionality!

I’m replying to keep this bug report active. I miss the share email link functionality!

Hello @lastgasp

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, we will get back to you as soon as possible.

Have a great day!

Thank you—standing by!

Hi again. I have an update. I looks like Brave has somehow hijacked the macOS (Monterey) Share Menu extension for Mail. The checkmark is grayed out, but there’s a Brave icon rather than a Mail icon. I’ll attach an image. When I trigger the share email link FROM Brave, the system appears to be looping back TO Brave, not to Mail. No wonder it’s not working. What do you suggest?

Hi again. Keeping this one alive while I pursue a solution. The “Mail” share menu extension is grayed out and is not designed to be editable. It’s not clear how Brave (note Brave icon has replaced Mail app icon) replaced the Mail app for that function, but it’s definitely caused a loop now. Any thoughts?

Well, here’s the solution to my own problem, thanks to “Barney-15E” in the Apple communities.

Somehow Brave changed the default email application selection in Mail settings. (I certainly didn’t change the setting myself, as I only use the Mail app.) Here’s the fix: “Mail > Preferences > Default email reader > Mail” fixed the problem instantly. The Brave icon persisted in the share menu extension, but the Mail icon may return after a restart.

Here’s a link to the solution:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.