Search does not load whilst connected to VPN

Whilst I’m connected to my VPN (Mullvad) I cannot use Search anymore. Whilst disconnected from it Search works fine. I don’t have this issue with any other site. It seems Brave blocks this popular VPN for some reason.

I’m going to start off by saying that I’m not that knowledgeable here in regards to Search, your VPN, or whatever else. So anything I say may not be much help at all. I just wanted to ask some things for more information. The hope is either the information helps clear things up for you OR at least provides more so those who do know what they are doing have more to work with.

So take it as you will and feel free to spend as much or little time answering questions or testing things. I’ll also tag @289wk and @Chocoholic who both tend to better than me on these things.


  1. What happens when you search? In other words, are you getting any errors or what do you see? (screenshot or video can help to try to see what’s going on).
  2. When you’re doing Search, have you tried both from the URL/Search bar and by searching at I’m curious if there’s any difference between the two?
  3. If you try in a New Private Window does it make any difference? If not, how about using a New Profile?

@Delbert_McCullough33 , @Saoiray

There are now 12 Mullvad issues, since year 2020:

May interest:

DNS leak when Brave browser configured to use a SOCKS5 proxy server!

Brave Search (beta) means to me, using:

. . . and the Search field (ie the Search Box) instead of the URL address field. (I never use the URL address field.)

I tested getting to and using:

via a Brave Browser >

  • New Private Window
  • New Private Window with Tor

I used for search criteria: ‘Mullvad VPN blocks Brave Search’

Reached Brave Search via both, but discovered that, when using Tor, I encountered a test:

I closed the New Private Window with Tor, and then tried it again. The second attempt did NOT include the robot test.

Clear DNS cache:

Using a Brave Browser > New Window, go to: brave://net-internals/#dns

  • Click on: Clear host cache

Close idle sockets and Flush socket pools:

Go to: brave://net-internals/#socket

  • Click on: Close idle sockets
  • Click on: Flush socket pools

Exit / Quit Brave Browser.
Restart your computing device.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

Otherwise - Extensions tests:

  • Disable
  • Remove
  • One-at-a-time
  • Combinations

Other applications, add-ons, plug-ins that are anti-virus and/or blockers.