Rewards not posting to gemini

Briefly describe your issue:
I linked my brave browsers with a new gemini wallet last month. For the months prior, I would manually have to “claim” rewards each month., around the 5th. As I understand it, when linking Brave to a verified walled, the tokens should be transferred automatically each month. The total BAT in my account has not gone up since I set up the account last month, despite having earned more BAT in the meantime. I figured I just needed to wait longer, since sometimes the transfers are delayed. However, the “Brave ads payout status” widget on this page indicated that gemini wallets have been paid. Gemini was yellow yesterday, (payment pending), but green as of last night; Still green today, and still no October transfer for me.

P.S. I have checked my “Brave Browser Rewards” icon in brave as well as my portfolio page on Gemini. They match, but haven’t increased BAT.

What Operating System and Brave version are you using (Menu --> About Brave)?
Linux Ubuntu 20.04, Brave 95.1.31.88

Is your browser wallet currently verified? (yes/no)
yes

What date did you verify your wallet?
Not exactly sure, some time in October.

Have you been able to successfully receive payments in the past?
This is the first automatic payment. I was able to receive the initial transfer from my browser to gemini when I set gemini up last month (I had a couple dozen BAT from previous months).

Are you using a VPN? (yes/no)
no

Are you in a supported region (see here for list of supported regions)?
USA

Does your device pass the SafteyNet check (Android only)?
Not android.

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

reward posted today, so I guess it just took a while.