won't load on Brave for iOS

  • Thread titles load but comments never load. It’s forever stuck on loading (the logo just pulsates endlessly)
  • AMP Reddit pages load fine
  • (i.e. desktop view) loads fine
  • Reddit loads fine in other browsers
  • Brave had no issues, then I logged out of my Reddit account one day and it stopped loading - no change even when I logged back into my account
  • I’ve tried uninstalling and reinstalling Brave, no effect.

How can this issue be reproduced?

  1. Visit in browser
  2. Brew a cup of coffee/tea
  3. Come back to find that Reddit still hasn’t loaded.

Brave v1.18 (

iPhone 6s, iOS 12.4.1

Hi @PPP88, Welcome to Community!
Can you try clearing your browsing data/history - does that affect load time?
Are you loading in desktop view?

Thanks Aaron.

Yeah I tried that out - doesn’t have any effect I’m afraid.

No, I’ve problems with loading the mobile version. Not the desktop one - I don’t have problems loading that yet.

I just tested this on my iphone 8plus; this is what I got:

Here’s a screen capture:

I only get issues If I enable “Block scripts and/or Block Phishing” in shields. Try disabling those options?

Thanks, that solved it. Script blocking was the cause (blocking phishing doesn’t present any problems, yet).

The tradeoff’s that I see ads on Reddit but I guess that’s another topic for another time.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.