PWA's Crash Immediately

Description of the issue:
How can this issue be reproduced?

  1. Install PWA (web app) from a site that supports it
  2. Try to run PWA

Expected result:
PWA runs like a native desktop app

Actual result:
PWA crashes immediately:

Brave Version( check About Brave):

Additional Information:
Trying to make Brave my daily driver and honestly this is a bit of a bummer. Didn’t work on Mojave and doesn’t work on Catalina.

Hello, @dustinlocke. It sucks that PWAs are not cooperating for you.

I tried installing and running the Twitter PWA in my Nightly install (1.5.27 Chromium: 79.0.3945.117 (Official Build) nightly (64-bit) on macOS Version 10.14.6 (Build 18G1012)) and downloaded the main release (1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit)) to try that, too. In both cases, I was able to quit Brave, launch the Twitter PWA, and browse Twitter successfully without changing settings.

I’ve not made the leap to 64-bit-only, yet, so my OS lags yours. That said, a few things might possibly cause issues:

  • Do you have any extensions installed?
  • Is your browser part of a Sync chain with an iOS device?
  • Are you running AV software, security software, VPN, or the like?
  • Have you tried clearing cookies and relaunching Brave?

@Mattches, any other ideas?

1 Like

Excellent support as usual, @hnktong.

I would also consider creating a new browsing profile (Main menu --> Create new profile) and trying to create a PWA from this fresh profile.

Also, to confirm, @dustinlocke – absolutely no PWAs work in Brave? For example, this site ( should allow you to install as a PWA – you get the same results when launching this site’s PWA as you do with others you’ve tried?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.