PWA’s Crash Immediately

Description of the issue: Since last update, no installed PWAs work (twitter, roam research, tasksboard). they all previously worked fine

Steps to Reproduce (add as many as necessary): 1. 2. 3. visit PWA-compliant site. install PWA. try to launch PWA.

Actual Result (gifs and screenshots are welcome!): Try to launch any PWA, it no longer works. A new window opens for an instant and then closes.

Expected result: PWA version of site launches in new window.

Reproduces how often: 100% of the time.

Operating System and Brave Version(See the About Brave page in the main menu):
Version 1.18.78 Chromium: 87.0.4280.141 (Official Build) (x86_64)

Mac OS Catalina 10.15.7 (Macbook Pro)

Additional Information: Have tried the following suggestions based on a January 2020 post of the same title, no help:
Removed all iOS devices from sync chain
Tried in a new profile with no extensions
Cleared cookies
Relaunched brave
Have confirmed that all these PWAs work as normal in vanilla Chrome.

Thanks!

@spoofhopper,
Thank you for the detailed report.
I can’t seem to reproduce this on my end – was able to install PWAs for Twitter without any issues. I’m reaching out to the team to see if there are any known issues for this at the time but I don’t believe that to be the case.

By any chance, are you running BetterTouchTool (or BetterSnapTool)? I believe there is an ongoing issue w/ some accessibility title being missing and several third party mac utilities hook into this causing a crash. I don’t know if this is related but wanted to just put the information out there if needed.


1 Like

Hi there - I’m not unfortunately. Any other ideas on other apps that might be interfering?

The particular bug I noted has to do with things that hook into accessibility services, so it could be a pretty wide variety of apps. If it is one of these apps causing the crash, you might be able to narrow down the list by looking at the Accessibility permissions under “Security & Privacy” system prefs. You could try toggling the permissions off, seeing if the PWA works, and if so, re-enabling them one-by-one until you find the culprit.

You were right! It turns out that RescueTime’s accessibility requirement was the culprit. Turned it off and PWAs work fine now. ¯_(ツ)_/¯

Glad I could help. @Mattches, are you aware of any movement on the accessibility bug? Didn’t seem to be much from looking at the other threads.