Problem, Brave shields they are disabled by default

Hey, I tried this and all shields are up when creating a new profile. Is this going to be fixed anytime soon tho as this was broken for quite some time and it’s such a hassle to start over everything again. I know there’s Sync but login details, rewards and stuff are not carried over.

My version: Version 1.38.111 Chromium: 101.0.4951.54 (Official Build) (64-bit)

i want to join conversation i am also facing problem where shield settings are changing to standerd whenever i exit the browser, bcoz i have set to clear history everytime i exit browser. i also find this annoying to change shields settings again to aggressive when i open browser, i hope you will fix it.

Note shields settings dont change if you don’t have set to clear browser history whenever you exit,

also remember if you use custom dns and block brave.com dns server so whenever you exit and start brave browser you will lose all blocking features

Same issue. Brave 1.38 on Windows and Mac.

Same issue here. Latest version,
Brave is up to date
Version 1.38.111 Chromium: 101.0.4951.54 (Official Build) (64-bit)

Same issue here as well. Shields are down everywhere, and I have to manually turn them on every time, even if they are set up correctly in settings and not included in the deleted data when browser is closed,
Creating a new profile solve the issue and the shields are up by default again, but that’s not a practical fix.

Hope for this to addressed soon :slight_smile:

Same issue here. Really Annoying.

I solved the problem, I deleted the Site and Shields Settings, and removed the sync with my cell phone, I was having problems receiving Ads from brave, I activated the brave://flags custom notifications

10 Likes

@JhonBlank , @Chocoholic ,

Excellent and daring - clearing the Site and Shields Settings. You [JhonBlank] were determined to fix the problem. Thank you.

1 Like

Solution works. Tested with randomly selected sites from search and all sites have shields enabled by default, including previous version shield enabled via flag.

1 Like

Just to add another confirmation that this indeed works. Kind of annoying since I had quite a few exceptions, but at least I have shields up by default. Hopefully we can get an update in hope this is not necessary in the future.

1 Like

Same problem. Hope an update will fix the bug

Sorry for any confusion this may have caused. To confirm, having this option set to be cleared either “On exit” or when you clear browsing data manually will reset Shields information. That said, it should still reset it to default settings, not turn Shields off by default.

On my end, when I clear browsing data with the Site and Shields Settings option selected, any settings for specific sites I had are cleared, but Shields revert to default settings and are up for all sites. Can anyone here who experienced this confirm for me whether or not it is the case that clearing browsing data with this option selected sets Shields to down for all sites?

1 Like

I deleted the sites and security settings and all sites returned to the Shields standard, I think my browser had this problem because I remember a short time ago having changed the shields to allow ads and cookies on all sites but shortly after I took it off this came the update of this new version I think it must have given some bug, I even remember the update because this version on mobile was going to add support for gemini.
Sorry for my english, i use google translator, i’m a user from brazil

1 Like

This one also worked for me, thank you!

1 Like

@Mattches I’m having the same problem, cleared all browsing data, reset browser, sync is turned off, any sites that I have manually turned shields on for in the last week still have shields up but any new site I visit has shields down by default. Running v 1.38.111 on OS X.

EDIT: The problem does not persist on a new profile however, which is very odd.

EDIT 2 (with apologies for returning again): reset all settings again, and now shields are working again. It’s definitely a bit annoying that I had to do that, but it’s working.

2 Likes

Clearing settings doesn’t work, but creating a new profile does.

This was working fine until I took brave shields down and back up a few days ago. Something corrupted the old profile.

I also have this issue on a brand new install on a brand new Windows 11 laptop. I’m not using an account of any kind to login to brave but all protection is disabled by default on all websites and its extremally frustrating and worrisome. Every website by default has no protections enabled.

Works as well! Thank you!!!

Will there be a fix? Won’t do this on all my pcs and other people still facing the same problem.

@DaReaLDeviL Brave GitHub issue report open and linked below. You may want to track the issue report to see if any progress is made.

Linked workarounds that have been posted that worked for some users below. If you haven’t already, you should test and see if they work for you.

Problem, Brave shields they are disabled by default - #21 by JhonBlank
post #21 above

Brave Beta Shield down by default - #5 by 289wk

Brave Shield not on by default - #3 by lastgasp