Private mode to not block all cookies by default

windows
privacy

#1

Hello,

by default the brave browser blocks all cookies while in private mode.
Is it possible to change the default to like only 3rd party cookies?

I am mostly using the private mode if I want to login to another account, but those sites mostly don’t work without any cookies, so I always have to manually turn it on.

Couldn’t find a setting for it, besides global shield defaults, which don’t work for the private mode and couldn’t find a related forum topic either.


#2

@Morgy By default 3rd party cookies are blocked for Normal/Private (Incognito) and Tor tab windows.

If you would like to Block all the cookies for all the sites, you will have to Change the Global shield settings to Block all cookies which will block all cookies for all the sites which you visit.

There is no separate rule for blocking cookies for Private (Incongito) tabs. It’s same for all the tabs.

Hope this will help.

Thanks!


#3

@gsarvadnya Thanks for your reply!

Well, that’s what I thought too, but that’s clearly not the case for me.

Global shield settings: block 3rd party cookies
Normal tabs: block 3rd party cookies
Private tabs: block all cookies

And even if I change it on the private tab, it resets after opening up another incognito session.

So maybe I found a bug? I can 100% reproduce this all the time.

Version 0.58.21 Chromium: 71.0.3578.98 (Offizieller Build) (64-Bit)


#4

@Morgy Just to understand what you have done, without changing Global shield settings you have visited a private tab and changed site shiled settings to Block all cookies and then you’ve opened another private tab and site shiled setting are ‘Bock 3rd party cookies’ is this your doubt?

If, so its behaving properly, because you have changed site shiled settings in one private tab and which should not reflect in another private tabs. Shield settings changed in 1st private tab are applicable to only that site.

If you’re seeing someother behavior please revert back.

Thanks!


#5

@gsarvadnya Nope, actually I did nothing.

Fresh install of brave.
Default settings then are block 3rd party cookies and this works flawless for normal tabs.
But if I then open up a private tab it’s not 3rd party cookies anymore, it’s then block all cookies.

I thought that’s due to the “even more privacy - mode”, but now it seems like a bug.

I then just tried to like open up google.com in private mode and switched the block all cookies to only 3rd party cookies. Closed the tab … reopened … went to google.com et voilà it’s back to block all cookies.
So even if I change it manually, it keeps resetting to block all cookies if a new incognito window is opened.
But global settings are on “3rd party cookies” all the time! Didn’t change anything on the global settings, nor somewhere else.

That’s why I thought settings are different for normal and private tabs, but you said no, so this seems like a bug to me.

Maybe this helps:


#6

@Morgy Thanks for the GIF which explains the issue clearly. You’re correct i could see in the GIF that, the cookies blocked is selected by default for PT’s . I guess the issue is due to Localization, not sure although.

Could you please provide below details:

  1. Browser is set to which language?
  2. Language set in OS settings?

cc @Mattches @sriram Can you guys throw some lights on this issue.

Thanks!


#7

I’m also thinking this is language related somehow. Would be interested in the answer to both of @gsarvadnya’s questions.


#8

Well, I don’t think it’s due to the selected browser language, since I used “English” before all the time. (Until I found out that every website then thinks I prefer their English translation as well :smiley: [Which is not the case, I just wanted the browser to be English because of the rather bad translation … ANYWAY …])
I just checked again … switched the language back to English and same behaviour. (Want a gif for proof? :b)

But to answer your questions:

  1. German (Germany) as well

#9

@gsarvadnya @Mattches did you gain an insight already? would really love to help “fixing this issue”


#10

It seems as though this is not intended behavior, but I’m unable to reproduce the issue on my end.
I’d like to give other users a bit more time to report similar activity and I’d like to get a confirmation from Security before logging it

Appreciate your patience on this!


#11

@Morgy Could you tell me how you are loading the private windows? The only concern for me is private tab shields doesn’t show up in German but the settings in normal window is all translated to German.

I am not able to reproduce the issue on Linux as well.


#12

@sriram It doesn’t matter if I just press ctrl + shift + n or via the menu and “New private window”.

Maybe the settings for the private window are not correctly loaded due to some language string?