Prevent the "Disable developer mode extensions" warning from popping up every time? i.e. permanently allow a specific extension

macos
#1

Description of the issue:

I’m using a self-made extension for automating certain tasks and some personal customisations. Whenever I start Brave, I get a warning about “Disable developer mode extensions” for security reasons.

I understand why this is. However the problem is, since I get this warning every time, I always close it without inspecting further. It becomes an automatic habit. This effectively nullifies the security.

Steps to Reproduce:

  1. Create a custom extension (or test with this dummy example - please see dummy.js to confirm it actually does nothing)
  2. Add the self-made extension through Settings > Extensions > Load Unpacked > select the folder containing the extension
  3. Restart Brave

Actual Result:

Expected result:

Something that would let me say “Always allow (this particular version of) this developer extension. Do not warn me again, but DO warn me if it changes or if other developer extensions are added”.

Reproduces how often:

Always (whenever I start Brave)

Operating System and Brave Version:

macOs 10.14.4 (Mojave),
Brave Version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit)

1 Like

#2

cc @toml @rossmoody on this.

Previously discussed here https://github.com/brave/brave-browser/issues/1432

0 Likes