Pocket Casts website not working in any capacity

Description of the issue

Once logged-in to the Pocket Casts website (podcast player), the entire page goes white.

  • Refreshing the page immediately does not fix the issue.
  • Cycling “shields up” (or down) does not fix the issue.
  • Refreshing the page after changing Shields up/down does not fix the issue.
  • Restarting the machine does not fix the issue.
  • Switching from macOS to Linux on boot (update: or seperate device) does not fix the issue.
  • The same web page works fine in Safari and Firefox

Exact URL of the website in question


[note: to verify this URL, an account with Pocket Casts is likely needed. 7-day trial accounts are available.]

Did the issue present with default Shields settings?
[Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)


Does the site function as expected when Shields are turned off? (yes/no)

NO (sometimes yes for a few seconds, until any link is clicked or page is refreshed, and then the DOM just shows pure white)

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)

YES, all configurations

Does the site function as expected when using Chrome? (yes/no)

Website (exact URL tested to be sure) works great with Firefox (macOS and Linux) and Safari (macOS and iOS)

I do not use Chrome and will not install Chrome.

What Operating System and Brave version/Build are you using when you encounter the issue?(See the About Brave page in the main menu)

  • macOS v.10.14.4 (18E226), with Brave Version 0.63.55 [Chromium: 74.0.3729.131 (Official Build) (64-bit)]
  • Ubuntu Studio Linux (v.unk), with Brave Brave Version 0.63.55 [Chromium: 74.0.3729.131 (Official Build) (64-bit)]

Screenshot attached:


Thanks for reaching out – excellent write up. Problem is that it’s so good I’m not entirely sure what to check here! :thinking:

Sometimes we get strange caching issues that present similarly – an easy test for this would be to visit the website in a Private window (or Private w/tor) and see if the issue produces the same. I don’t think this is the issue but it’s an easy test – definitely worth trying. Let me know what you find.
In the meantime, I’ve pinged a couple team members and will test the site on my end to see if I can produce the same behavior. Appreciate your patience.

Well that was fast – I think I found the issue. In your initial post, you state,

To confirm, does this mean immediately after login – that is, you’re unable to land on any page? I ask because I was able to get the site up and running during testing. Process used:

  1. Opened new Brave Release (v0.64.75) window
  2. Navigated to pocket casts website with the link you provided (signed up for trial)
  3. Landed on the “Discover” page – this is where the confirmation above comes from as I didn’t have to make any adjustments to get to this point.
  4. Selected a podcast on the Discover page, and was then shown the blank white screen you describe in your report.
  5. I was able to navigate back to the discover page, which again displayed as intended. Selecting a different podcast again produced the same result – however, this time, I noticed the browser alert that autoplay for the page had been blocked.
  6. After allowing autoplay for the site and refreshing, I was able to listen to podcasts and view all pages without issue.

I notice in the image you shared, the right-hand side of the address bar is cropped out – this is where you’d see the Autoplay was blocked on this page message:

Do you see this alert when you visit the site? If so, try allowing autoplay and refreshing. If not, click the “lock” icon on the left side of the address bar --> Site Settings --> Autoplay and set this to Allow.

Let me know if this resolves your issue.

1 Like

Hey, and thanks for the help so far!

Yes, I did make sure that autoplay was enabled. (I’ve also tried it with and without shields), and the problem unfortunately persisted.

The problem is following me between two physical computers (macOS on laptop and Ubuntu Studio on desktop), if that helps with anything.

As for private window w/wo Tor, I did try that again (just now) and still see the problem there.

EDIT: I just saw your question about the white screen (Immediate, or not?) to answer frankly… it depends, and seems random! Sometimes I can see the podcast tiles, sometimes I can get to the play screen, and sometimes… sometimes I can even start playing one (maybe 1 in 50 tries) before the screen/DOM goes white!

I hope this helps, haha.


Well that is interesting – not sure I’ve ever seen something like this appear intermittently as you described. Would you mind showing me the console output when you visit the site? If you’re unsure how to do this:

  1. Open the main menu
  2. Navigate to More Tools --> Developer Tools
  3. Select the Console tab in the Dev tools window
  4. Visit the site so the issue produces

Copy/past or screenshot the console output so we can see whats happening under the hood.

I can confirm the problems also happens on my PC. Here’s the attached log from the console:

The site also works on Chrome.

1 Like

Have you been able to fix this problem? I’m encountering the same thing where it will load briefly and then flash white with about a 1/50 chance to get a podcast working. This occurs with all shields down, all extensions disabled and autoplay on, as well as after clearing the cache.

Using pocketcasts in chrome works just fine, however.

Hi Mattches,

Were you able to sort out this problem? I’m having the same issue as Neon25 but I don’t see a response to his log. Would it help to include a log from my console as well?

Thank you for bumping this thread.

You can never provide too much information! :slight_smile:
I’ve reached out to some team members for additional input as it’s still not entirely clear what the issue is.
Appreciate everyone’s patience on this.

1 Like

Hopefully this helps!

1 Like

I get this same
cast_sender.js?loadCastFramework=1:2 GET chrome-extension://invalid/ net::ERR_FAILED
l @ cast_sender.js?loadCastFramework=1:2
m @ cast_sender.js?loadCastFramework=1:1
(anonymous) @ cast_sender.js?loadCastFramework=1:2
(anonymous) @ cast_sender.js?loadCastFramework=1:2
cast_sender.js?loadCastFramework=1:2 GET chrome-extension://invalid/ net::ERR_FAILED

but sometimes it comes back after a refresh

1 Like

Hi Mattches,

Is there any word on a possible fix for this issue?

Also… bump i guess

I guess my fix didn’t help :confused:

Maybe related to the issue on Dailymotion is not working in Brave Am seeing cast_sender.js errors.

This topic was automatically closed after 30 days. New replies are no longer allowed.