Payment not received in Gemini

17.68 BAT gone, basically my entire rolled over balance from months in my Android Stable Brave, updated to the latest version, always open in background. Saturday 9th I see the red dot in the BAT icon, so I claimed my earnings and did the same in my Win 10 (also Stable latest version, both linked to my Gemini account). An internal deposit of 12.5 BAT from my pc browser came shortly after, but the 17.68 from the phone never arrived, it was too early to complaining cause Gemini payments status was still pending, but it’s clear now that the system failed to process it, since the other took less than 2 minutes and now are more than 48 hours from the claiming. I already contacted support center, got a ticket in progress but situation is stuck. I tried my best to provide all needed info (ID Wallet, browser version, OS, date/time of the claim, Gemini account, pictures of my rewards page), as well my expected balance to come, although mobile browser doesn’t have history payments page, only a banner saying “Your 17.68 rewards are on the way” before and “Congrats! Your rewards are arrived” then. In case some @mods want to help me, 143430 is my ticket. Thanks.


Nah, It does have a history page just like in the computers. Go to “brave://rewards-internals/” and check the event logs to see if anything actually processed.

If it shows you the transaction that you were expecting, add it in your list of proofs for your ticket.

Now my registry events show the promotion claimed in question, even if it should be 17.68 the value is now 15. But still no transaction arrived.


Edited with my phone, I know it sucks.

I disconnected my account, took pictures of rewards, then relinked to see if something moves. This is it:
Brave linked to Gemini account, balance of 114 BAT without 15 (17.68) BAT to be deposited


Brave disconnected account, empty balance but with a reward of 15 BAT from July

@Saoiray, have you any idea what’s wrong?

Same thing has happened to me. Claimed rewards on work computer and home computer. Only one was deposited into Gemini. My issue was knowing which one was deposited because they were the same amount. By disconnecting the wallet like you did, I think that helped me determine which one.
Have you gotten any feedback from support on this?

Yes, I sent them all the info available and they simply told me if after the full Gemini payment process I still have the issue, then probably I’ll get it the next month. Not much encouraging, nothing specific, a bit disappointing, even cause it was my entire rolled over balance from months, and mostly cause if the support team recognize the problem i would expect they’d try to fix it, not to tell me “maybe the next time” answer. They keep saying to update to the latest version, to keep running browser in background; to me are all unrelated advices to my issue, but still I do it always.

Nothing looks wrong here so I have no clue why your payments are not processed. Kind of same thing happened with one of my devices but when I checked through rewards-history, it wasn’t there so my doubt was clear that the payment never processed through brave but your device is at least showing 15BAT.

I would suggest raising a ticket at Gemini help center, attach this history page too. Maybe they can help. That’s your last resort I guess at this point.

Also, please reply to the people’s answer and not your thread. I got no notification for all of your replies.

Already raised a ticket in Gemini, kind of trying to knocking all the doors.

What I don’t understand is why it’s showing the 15 BAT only when the wallet is disconnected. In the previous months, it would show the cumulative amount between the verified wallet (Gemini in my case) and the claimed rewards, even before the amount was transferred to the verified wallet. Now the claimed reward seems to be hiding in limbo.

1 Like

Regarding my issue about the missing but claimed payment, it’s been solved today, so thanks to all the team for the effort, even with this hot :slightly_smiling_face:.