Password autofill does not disable

Description of the issue: Password autofill still appears even after disabling it as much as possible in Brave options.

**Steps to Reproduce (add as many as necessary): Navigated to a variety of websites with saved login info. The autofill always appears regardless of autofill settings.

**Actual Result (gifs and screenshots are welcome!):**The autofill always appears regardless of autofill settings.

Expected result: Autofill should not appear when its fully disabled.

Reproduces how often: Always.

Operating System and Brave Version(See the About Brave page in the main menu): Win 10 Version 0.69.132 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Additional Information: Add a password generator and I won’t need Dashlane.

I have the same issue on Brave for Android 10.

Even though I have deleted all saved logins and disabled everything related to saving credentials in the Brave settings, Brave still shows the pop-up for auto fill (with the the credentials that I already deleted).

Doesn’t exactly inspire confidence from an OPSEC point of view!