Outlook is not working on Brave with Version 1.12.112 Chromium: 84.0.4147.125 (Official Build) (64-bit)

Description of the issue:

With the new version of Brave I installed yesterday on Ubuntu 20.04, I find that today I cannot read my university email on OWA. The same problem occurs on 14.04. I get a loop that sometimes results in an error message, but sometimes does not terminate. I have no trouble on Google Chrome or Mozilla Firefox.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

I try to connect to mail.iu.edu/owa . I am asked to authenticate, but then it goes into a loop with two other intermediate sites. I have tried with shields down and all allowed. I tried clearing cookies and cache.

Actual Result (gifs and screenshots are welcome!):

When I get an error, it is this:

Indiana University (ADS)

An error occurred

An error occurred. Contact your administrator for more information.

Error details

  • Activity ID: 00000000-0000-0000-991c-0080010000c3
  • Error time: Sun, 16 Aug 2020 14:08:13 GMT
  • Cookie: enabled
  • User agent string: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36

Reproduces how often:

Every time if the loop terminates.

1 Like

Update: the problem is the same with the latest version, Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) unknown (64-bit)]. Furthermore, my university’s IT says, “I’m afraid OWA does not currently work with Brave. We believe this is due to some changes Brave made that make it similar to Firefox in private browser mode, which is also incompatible.”

Same here. OWA not working in brave 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit) on either Ubuntu or OS X. Chrome of the same build works fine on both platforms. I have tried new profile, no extensions, seemingly every privacy feature turned off, and it still does not work. I understand that OWA may not be available to Brave developers. Is there any debug info we could provide to help identify problem and get it fixed?

Update: still not working in Version 1.13.82 Chromium: 85.0.4183.83. I wish there was a real bug reporting system for brave instead of these forum threads that no brave developers read. Sigh.