Onedrive sign in issue

Went to lunch and came back and nothing I had open in my one drive would cooperate with a strange error code. Tried opening onedrive homepage and asked for sign in, when I click on my account it just refreshes the accounts available for sign in. Do this enough and I will get 1 of 2 random web error pages. Was across multiple browsers but I was able to eventually backdoor into onedrive in edge but sign in with brave is still a no go.


I am having the same issue. Exactly as you described. I was also able to back door using safari however this is really annoying as Brave is my default browser

Same here.

Description of the issue:
For the past 2 days brave is not opening office files (Word, Excel, PowerPoint) in their respected app online. Instead I a prompted to either login and then I have no access. These are my files so permissions is not an issue. This was working a couple days ago. I am not seeing the same issue in Edge or Firefox. They are functioning normally.

Steps to Reproduce (add as many as necessary):
Launch Brave
2. Visit > when I open any file stored

Actual Result
Office prompts for sign in and saying access denied

Expected Result:
Office files stored in to open in browser app (Word, Excel, PowerPoint)

Reproduces how often:

Brave Version(See the About Brave page in the main menu):
Brave release - v1.63.162 (Feb 23, 2024)

Reproducible on current live release (yes/no):

Additional information:
I’m using macOS Sonoma v 14.3.1 (23D60)

Issue still present as of this morning, this is gonna make life difficult because I basically have to work out of Edge to make it work and the structure is all different and going to slow me way down. Eventually last night I was able to get in through and can see the files and apps there but when trying to open one drive instead of the login issue it just endlessly attempts to load with a blank page.

I’m having a similar issue. I have two Microsoft accounts and use two different profiles. I can access email, Teams, etc. but once I try to use the root SharePoint site or open a file in OneDrive, I get this error saying I can’t be signed in. Please try again. Looking at Entra logs, I don’t see any issues.

Problem still present this morning, yes I got to a point where I can access everything except onedrive. Not sure how to navigate to entra logs.

Having the exact same issue this morning. I can log in to outlook, word and excel online, teams, etc. However, when trying to open any given file, the “can’t sign in” onedrive page shows up

Same with me. If this issue lasts long enough then I will have to move off of Brave entirely (which I don’t want to do).

For work at least for me which is a huge bummer.

Does anyone know how long it usually takes for issues like this to be resolved? First time on the Brave chat boards

1 Like

Add me to the pile of people who cannot access work docs via SharePoint or OneDrive on Mac OSX Sonoma 14.3.1 in Brave 1.63.162.

1 Like

Usually they close or lock the thread without a solution. Never saw anything solved within 60 days of a report, but maybe they will prove me wrong!

Been experiencing the same issues for the past week now. Updated Brave to the latest release. Cleared all browsing data… Created a new account and logged in from that new account. But it works with Safari

Moved to a mac mini that has never had Brave loaded onto it. Same issues where it continues to deny my login even though i’m logged into the admin app and other apps from

However, when I tried from my iPhone or iPad, there was no issue. all on the same network.

OSX 14.1.1 Sonoma

1 Like

This is a known issue that the team has already pushed a fix for and are working on an uplift to release build:

1 Like

Same problem here. Since a couple of days I cannot access Onedrive using Brave.
I am redirected to some kind of OneDrive landing page that has a login button.

Sometimes I see this message flicker by:
"Cannot read properties of undefined (reading ‘indexOf’)

1 Like

This issue is happening for one of my users still. Is there a resolution for this? They have the latest version of the browser.

There are some variation of the problem, but i think they are all the same. Starting OneDrive at the office webpage results in forwarding errors. It is the same on all workstations and also verified the issue by a friend. In my case i use Microsoft Office 365 Family Edition. When starting OneDrive at the “” i land on an “about:blank” page. By directly using the link “” everything is working fine. Swapping between users adds additional problems but can be fixed by refreshing the page.

Appears to be working this morning.

Not for me, I cannot log into onedrive, I can with Edge but not with Brave.

Where are the patch notes?