noVNC no longer receiving keyboard input

We use Proxmox and discovered that the latest update to Brave broke keyboard input to noVNC for accessing the consoles of our VMs. We type on the keyboard, but characters don’t show up. We discovered this on an M1 Max running macOS 12.3.1. FireFox and Google Chrome work fine.

@wavesound ,

May be stranger than fiction, but the following might be related(?!):

Another recent problem that causes a variety of issues/symptoms . . .

See: Problem, Brave shields they are disabled by default - #7 by Mattches

and the next reply, there.

@289wk I disabled “Auto-redirect AMP pages” and I didn’t see any changes in the behavior. I’m not sure how this would be related since the shields are not blocking anything and the Proxmox has no links to google…?

@wavesound ,

The “de-AMP” thing, part of the Brave Browser v1.38.109 update, is causing a variety of issues, including input . . . so the possible fix (for the moment); was all.

I took a look at the Brave Browser > Developer Tools for Proxmox, and the results show that Proxmox is all Proxmox.com serving. You certain could “safely” lower the site-specific Shields (Lion icon) panel for Proxmox.com.

And, you could “safely” lower the site-specific Shields (Lion icon) panel for noVNC.com.

But the problem is likely with noVNC and Brave Browser; a WebSockets and port numbers thing (and possibly DNS).

You might try . . .

In a Brave Browser > New Window, go to: brave://settings/cookies

Disable: Clear cookies and site data when you close all windows

Next, go to: brave://settings/clearBrowserData . . . and select the Clear browsing data > Basic tab.

Enable all 3 selections and click the Clear data button – BUT NOTE: the Clear cookies and other site data selection (when Enabled) will sign you out of most websites.

Return to: brave://settings/clearBrowserData

For the Clear browsing data > On Exit tab:

  • Disable: Passwords and other sign-in data
  • Disable: Site and Shields Settings

Click on the Save button.

In a Brave Browser > New Window, go to: brave://net-internals/#dns

and click on Clear host cache

Next, go to: brave://net-internals/#sockets

and click on both (in succession):

  • Close idle sockets
  • Flush socket pools

Exit/Quit everything and restart your computer.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

In a Brave Browser > New Window - go to: brave://settings/security

Disable: Use secure DNS

And maybe . . . in a Brave Browser > New Window, go to: brave://settings/?search=Continue+where+you+left+off

And adjust the settings to about:blank as shown;

I admit to not liking the “Continue you left off” thing – because I would not want Brave Browser to continue with a problem website. Better, in my view, to start up Brave Browser with a minimum of immediate challenges/jobs.

@wavesound ,

Maybe the media keys problem

None of these suggestions are related to the problem…and did not help.

This has been fixed. I’m not sure quite how, but its working now.