Night mode breaks QR codes


Description of the issue:
Night mode breaks QR codes

How can this issue be reproduced?

  1. Go to prime account
  2. Go to your cart
  3. Click whole foods code

Expected result:
QR code appears, use to scan. Instead have to turn off night mode for it to scan.

Brave Version( check About Brave):

Mobile Device details
Samsung S9+

Additional Information:
I love night mode :slight_smile:


Hello there @shneebz please accept my apologies for this issue, could you please see if there’s an update available for Brave on the Playstore to see if this solves the issue?

Thank you. I updated Brave and will try it out tomorrow. However, I don’t think there’ll be any difference as the dark page still envelopes the whole QR code on the Amazon page, which I suppose confuses the QR code reader.

1 Like

@shneebz no worries, please let me know if the issue persist on your mobile device in order to make further investigation.

Night mode need way too much improvement as you can see from my screenshot, see the white colour at the top I faced this issue with many different sites.

1 Like

Hi there @OshekharO does the same behavior repeat if you open that page on incognito mode? Also please provide me with your mobile device details and Brave version in order to investigate further.

Yes, it repeats even in incognito mode.

Device: Realme 7 Pro
Android: 12
Brave: 1.48.160

P.S. Have been facing this issue since long time. Also please fix auto translate it takes too much time compared to chrome. I am not able to completely move from chrome to brave mostly due to 2 reasons my bookmarks in chrome and translation function.

1 Like

@OshekharO please go to brave://flags/ > Search for Auto Dark Mode for Web Contents > Enable.

Let me know if that changes anything.

I have already enabled that option but still haven’t seen any improvement.

Also I am facing similar issues on this page:

1 Like

Hi there @OshekharO, please try the following to see if you are able to solve this issue:

  1. Open Brave
  2. Click on the three dots menu and click on accessibility
  3. Turn Simplified view for Webpages off/on

Let me know if that works.

No, still not working facing same issue on multiple websites.

1 Like

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, I will get back to you as soon as possible.

It is worth mentioning here that the “night mode” feature is experimental and comes built-into the Chromium engine. Changes to it’s code are typically not made by us (at this time) and some wonky behavior is expected.

I will pass this information to the Android team for review and to see what we can do on our end.

Thanks and also if possible please reduce the time required for brave translate ( auto translate ). @Mattches

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.