NET::ERR_CERT_INVALID only on Desktop

Description of the issue:
Multiple financially related websites return a “NET::ERR_CERT_INVALID” = “Certificate is not valid” error, e.g., websites for
discover, americanexpress, citi, usaa, experian, https://secure08ea.chase.com/web/auth/dashboard

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Launch Brave browser
  2. Type in URL of any of the aforementioned websites
  3. I receive the “Your connection is not private” error

Actual Result (gifs and screenshots are welcome!):
These are screenshots from Brave tabs for the previously mentioned URLs, including certificate information:


Expected result:
These images are how these URLs should appear (screenshots from Firefox browser)


Reproduces how often:
Recurs always with the same URLs

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Pro, 22H2
[Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (64-bit)]

Additional Information:

  • Note that I do NOT receive the error with the root domain for Chase but I do get the error with the Chase subdomain noted above
  • Also note that I do NOT have this issue with any of my other computers including a laptop and my Chromebook. Nor do the issues occur when I navigate to the same URLs using Firefox or Edge browsers.
  • I started having this issue after I synced up my devices (never having done so before).
  • I’ve removed all extensions, cleared my cache, removed sync, reset settings, even uninstalled and reinstalled Brave, but the issue persists.

@EVAyson Just out of curiosity, do you use Avast? If so, try to disable it. Or can check with whatever firewall/antivirus/vpn you’re using to see if it creates conflict. Part of where I’m asking is someone had a similar situation with a different site. They found that Avast was causing issues.

EDIT

Actually, just looked closer at what your screenshot shows. And yes, your error message does say Avast. So that likely is your culprit.

I am facing exact same issue as @EVAyson with self signed certificate. Suddenly today Brave is displaying warning page without possibility to accept risk (two days ago everything was fine - certificate is installed in system, so Brave was recognizing it properly). Certificate is of course still valid.
Using Edge everything is working.
With Brave on Android everything is working too.

@fapped OK. So did you check what I said? Is your issue with Avast?

Ahhh, sorry, forgot to mention it - I have never used Avast on this machine, to be more precise - there is only built-in MS Defender since installation of Windows.

–EDIT–
Reinstallation is not changing anything

It indeed appears that the Avast feature “Web Shield” is the culprit. Interesting that it would start acting up like this after having no apparent problems previously. I’ll def send Avast a trouble ticket. Thanks for the fix!

Specifically, it’s the HTTPS Scanning feature of the Web Shield function that is causing the problem. One workaround is to configure any website URL(s) which trigger the error message into the Exception list on the 3rd tab in the Web Shield screen.

However if, like me, you’re unclear as to what value is added by this feature and you’re reluctant to maintain a list of URLs within an application without assurance that an external copy isn’t being maintained by the vendor, then the alternative workaround is to un-tick the HTTPS Scanning checkbox on the Web Shield screen.