MacOS Notifications have never worked

Briefly describe your issue:
Since using this browser I have not once received a notification popup for Ads (but I do get Sponsored Images and have accumulated BAT from them). I have tried I think pretty much every suggestion out there, including:

  • Notifications are set to use Google services for pushes in Brave
  • Updating both OS and Browser
  • Ensuring Do Not Disturb is not on in settings, and that Notifications are turned on for Brave
  • Tested browser’s capability of sending a push notification through https://www.bennish.net/web-notifications.html
  • I know I am in a supported region, plus: I can confirm I see multiple “Sponsored Images” per day, and I also have this browser on my iPhone + Android phone and both of these get push notifications without any issues

I also have this installed on my personal mac as well as this work mac, both connected to the same verified wallet, both unable to receive push notifications it seems.

What Operating System and Brave version are you using (Menu --> About Brave)?
Brave: 1.25.68
macOS: Big Sur 11.4

Is your browser wallet currently verified? (yes/no)
yes

What date did you verify your wallet?
About a week ago?

Have you been able to successfully receive payments in the past?
not yet

Are you using a VPN? (yes/no)
no

Are you in a supported region (see here for list of supported regions)?
yes

@Nothadoth,
Thank you for providing all the requested information. That said – would you please send me a DM with your wallet ID found on your brave://rewards-internals page?

1 Like

I amalso having the same issue on my mac. Unable to receive ads notification.

Unfortunately I haven’t yet had any good reason for this to be the case, and the DMs to help me resolve the issue have gone cold. It seems Brave don’t have an answer for this other than “there must be no campaigns for you”. :man_shrugging: yet I pull out my iOS device to answer this and receive an ad immediately. From the couple of threads I have opened it seems to me that there are many people facing this same issue, and that’s backed up for me by the fact that the advertisements work perfectly on every device I use except Mac.

I think it just doesn’t work on Linux.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.