MacOS: New Window opens a Private window when already within Private window

Description of the issue:
On MacOS, if a private window is open and you right click the Brave icon in the dock, when you select “New Window” (NOT New Private Window), it just opens another private window.

How can this issue be reproduced?

  1. Open incognito window on MacOS
  2. Right click Brave icon on dock
  3. Select New Window (NOT New Private Window)

Expected result:

A non private, normal, window should open, not open an private browsing window

Brave Version( check About Brave):

Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (arm64)

Additional Information:

This could be by design, but it seems silly that the option to open a new private window is right below the new window option, and the new window option has the same result as the new private window.

1 Like

Hello there @0diferous thanks for our report, please try disabling hardware acceleration to see if that makes any change.

To disable Hardware Accelertation through the macOS terminal. Follow the instructions below:

Open the Terminal and enter this command: open -a "Brave browser.app" --args --disable-gpu

Let me know if that works.

Unfortunately the same behavior when using that command.

1 Like

So, when you go to the top right three line menu, and select New Window, it works as expected, it’s just the New Window option from the dock icon that doesn’t work.

1 Like

Hi again @0diferous try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Hello, I have the exact same issue and can confirm that no extensions are installed.
Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (arm64)

1 Like

Hi there @ulib please accept my apologies for this. Which MacOS version are you running Brave on your Mac?

Hi, it is the latest version: macOS Ventura 13.1
Also Brave is updated to Version 1.47.186 Chromium: 109.0.5414.119 (Official Build) (arm64) but the issue remains. Please let me know, if I can help in any way or form.

Uli

1 Like

@ulib please try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Hi, I have installed Nightly and the behaviour is the same. The issue persists.
Thanks

1 Like

@ulib does the same behavior occurs on other chromium based browsers such as Chrome, Edge, etc.? Please try repeating the same steps on other browsers to see if you get the same result.

Be waiting for your response.

Good guess. I tested with Google Chrome Version 109.0.5414.119 (Official Build) (arm64) and can confirm that the behaviour is the same in Chrome and in Brave.

Sorry for the late answer.

1 Like

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, I will get back to you as soon as possible.

1 Like