Linux: new glibc version dependency has removed beta from all centos7/rhel7

Description of the issue:

centos7. brave-browser-beta 0.63.29 now depends on glibc 2.18. centos7 and rhel7 are currently up to only 2.17, ergo the entirety of centos7 and rhel7 has been removed from beta usage. if this new configuration goes main at some point, you will cut off centos7 and rhel7 from brave entirely.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. yum update
  2. thud
  3. headdesk

Actual Result (gifs and screenshots are welcome!):

–> Running transaction check
—> Package brave-browser-beta.x86_64 0:0.62.37-1 will be updated
—> Package brave-browser-beta.x86_64 0:0.63.29-1 will be an update
–> Processing Dependency: libc.so.6(GLIBC_2.18)(64bit) for package: brave-browser-beta-0.63.29-1.x86_64
–> Finished Dependency Resolution
Error: Package: brave-browser-beta-0.63.29-1.x86_64 (brave-browser-beta)
Requires: libc.so.6(GLIBC_2.18)(64bit)

Expected result:

normal update.

Reproduces how often:

always.

Brave Version(See the About Brave page in the main menu):

see above.

Reproducible on current live release (yes/no):

yes

Additional Information:

for currently-installed previous release, 0.62.37:

rpm -q --requires brave-browser-beta | grep -i glibc
ld-linux-x86-64.so.2(GLIBC_2.2.5)(64bit)
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.11)(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.15)(64bit)
libc.so.6(GLIBC_2.16)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.2)(64bit)
libc.so.6(GLIBC_2.3.3)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.6)(64bit)
libc.so.6(GLIBC_2.7)(64bit)
libc.so.6(GLIBC_2.9)(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.12)(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.3.2)(64bit)
libpthread.so.0(GLIBC_2.3.3)(64bit)
librt.so.1(GLIBC_2.2.5)(64bit)

i’ve had to remove brave-browser-beta in order that other packages be updated. no, i won’t include --skip-broken from now until eternity.

1 Like

just fabulous, folks.

i filed this report on apr 03. it has gotten literally zero attention. i warned at the time that you were in danger of closing out the entirety of rhel and centos if this glibc dependency was left unaddressed, and propagated to non-beta.

so guess what? today, with 0.62.51-1 installed on up-to-date centos7.6, yum update tells me that it tried to get 0.63.48-1, which fails because of the glibc dependency.

i guess i’m moving back to chrome, because there’s no way i’m running a browser that is actually unable to update.

Error: Package: brave-browser-0.63.48-1.x86_64 (brave-browser-release)
Requires: libc.so.6(GLIBC_2.18)(64bit)

1 Like

I have a RHEL7 machine too. Looks like I just missed the cutoff by a few days to download brave for it :frowning:

It’s a bummer because I’ve just downloaded Brave on my two windows10 machines and was hoping to use it at work too. But, oh well.

@vanillaknot I’m new to this forum but do you think it would make sense to update the tags to include the main version as well as beta?

i don’t see a tag available from tag editing/search that would give new indication of main build along with beta. at best i see an either/or.

what alarms me the most is that it has now been just short of a month, and it appears that no one in brave development has even noticed this report.

what a great way to build confidence among the users, guys. “here’s a whole community of people wanting to improve the program… just don’t count on anybody actually, you know, listening to you.”

Just when I was using Brave as my everyday driver. Now it wants glibc 2.18 and Centos 7 is running 2.17.

Installed using yum with the brave release repo. This sucks. Tried to update to 0.63.55.

—> Package brave-browser.x86_64 0:0.60.45-1 will be updated
—> Package brave-browser.x86_64 0:0.63.55-1 will be an update
–> Processing Dependency: libc.so.6(GLIBC_2.18)(64bit) for package: brave-browser-0.63.55-1.x86_64

Hope it gets fixed.

I’d posted about this too. Some support staff said I needed to update the keyring. LOL. I said that the prob is that it was compiled using 2.18. So I guess nothing will happen on this.